configure: add '-Wredundant-decls' to warning flags
[lttng-tools.git] / tests / regression / tools / filtering / Makefile.am
index 919307e175b79a8c000bf4e9fc10cb01f6483167..4a851c32ff17ef8c61316619ca62979c37000f5e 100644 (file)
@@ -3,6 +3,13 @@
 AM_CPPFLAGS += -I$(top_srcdir)/tests -I$(srcdir)
 
 if HAVE_LIBLTTNG_UST_CTL
+# Disable some warnings flags to accomodate the tracepoint headers
+WARN_FLAGS = \
+       -Wno-redundant-decls
+
+AM_CFLAGS += $(WARN_FLAGS)
+AM_CXXFLAGS += $(WARN_FLAGS)
+
 noinst_PROGRAMS = gen-ust-events
 gen_ust_events_SOURCES = gen-ust-events.c tp.c tp.h
 gen_ust_events_LDADD = $(UST_LIBS) $(DL_LIBS)
This page took 0.023495 seconds and 4 git commands to generate.