Fix: added missing test_channel and removed double defined test_syscall
[lttng-tools.git] / tests / regression / kernel / Makefile.am
index 28e0303e20f42d49c30593d1bffccb8770a9214d..040b76423a207e45494cd75107d4280b392aab3a 100644 (file)
@@ -1,16 +1,25 @@
 # SPDX-License-Identifier: GPL-2.0-only
 
-EXTRA_DIST = test_event_basic test_all_events test_syscall \
-               test_clock_override test_rotation_destroy_flush \
-               test_select_poll_epoll test_lttng_logger \
-               test_userspace_probe test_callstack \
-               test_syscall validate_select_poll_epoll.py \
-               test_ns_contexts test_ns_contexts_change
+
+EXTRA_DIST = test_all_events \
+                                                test_callstack \
+                                                test_channel \
+                                                test_clock_override \
+                                                test_event_basic \
+                                                test_kernel_function \
+                                                test_lttng_logger \
+                                                test_ns_contexts \
+                                                test_ns_contexts_change
+                                                test_rotation_destroy_flush \
+                                                test_select_poll_epoll \
+                                                test_syscall \
+                                                test_userspace_probe \
+                                                validate_select_poll_epoll.py
 
 noinst_PROGRAMS = select_poll_epoll
 select_poll_epoll_SOURCES = select_poll_epoll.c
 select_poll_epoll_LDADD = $(POPT_LIBS)
-select_poll_epoll_CFLAGS = $(POPT_CFLAGS) -fno-stack-protector -D_FORTIFY_SOURCE=0 $(AM_CFLAGS)
+select_poll_epoll_CFLAGS = $(POPT_CFLAGS) -fno-stack-protector -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=0 $(AM_CFLAGS)
 
 all-local:
        @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
This page took 0.023797 seconds and 4 git commands to generate.