port: build kernel tests only on linux
[lttng-tools.git] / tests / regression / Makefile.am
index 222635d339d65e434ffe3eab642cc0fa374080d3..1ff5ad7f398569b6650d67bdb74cfe9f687af853 100644 (file)
@@ -1,6 +1,6 @@
 # SPDX-License-Identifier: GPL-2.0-only
 
-SUBDIRS = tools kernel ust
+SUBDIRS = tools
 
 LOG_DRIVER_FLAGS = --merge --post-script $(top_srcdir)/tests/utils/warn_processes.sh
 LOG_DRIVER = env PGREP='$(PGREP)' AM_TAP_AWK='$(AWK)' $(SHELL) \
@@ -50,6 +50,7 @@ TESTS = tools/base-path/test_ust \
        tools/notification/test_notification_multi_app \
        tools/rotation/test_ust \
        tools/rotation/test_kernel \
+       tools/rotation/test_ust_kernel \
        tools/rotation/test_save_load_mi \
        tools/rotation/test_schedule_api \
        tools/metadata/test_kernel \
@@ -64,6 +65,11 @@ TESTS = tools/base-path/test_ust \
        tools/trigger/name/test_trigger_name_backwards_compat \
        tools/trigger/hidden/test_hidden_trigger
 
+# Only build kernel tests on Linux.
+if IS_LINUX
+SUBDIRS += kernel
+endif # IS_LINUX
+
 if HAVE_LIBLTTNG_UST_CTL
 SUBDIRS += ust
 TESTS += ust/before-after/test_before_after \
@@ -98,6 +104,19 @@ endif # TEST_JAVA_LOG4J2_AGENT
 
 if IS_LINUX
 TESTS += \
+       kernel/test_all_events \
+       kernel/test_callstack \
+       kernel/test_channel \
+       kernel/test_clock_override \
+       kernel/test_event_basic \
+       kernel/test_kernel_function \
+       kernel/test_lttng_logger \
+       kernel/test_ns_contexts \
+       kernel/test_ns_contexts_change \
+       kernel/test_rotation_destroy_flush \
+       kernel/test_select_poll_epoll \
+       kernel/test_syscall \
+       kernel/test_userspace_probe \
        ust/namespaces/test_ns_contexts \
        ust/namespaces/test_ns_contexts_change
 endif # IS_LINUX
This page took 0.025058 seconds and 4 git commands to generate.