Namespace lttngctl filter flex/bison symbols
[lttng-tools.git] / src / lib / lttng-ctl / filter / Makefile.am
index 85a427447c39d88061257745011bb2c9bcf5ac42..4ff345aa4c3d18097e0965026cac9ea8b5fccf78 100644 (file)
@@ -3,7 +3,8 @@ AM_CPPFLAGS = -I$(top_srcdir)/include -I$(top_srcdir)/src \
 
 noinst_PROGRAMS = filter-grammar-test
 noinst_LTLIBRARIES = libfilter.la
-noinst_HEADERS = filter-ast.h
+noinst_HEADERS = filter-ast.h \
+               filter-symbols.h
 
 BUILT_SOURCES = filter-parser.h
 AM_YFLAGS = -t -d -v
@@ -20,6 +21,7 @@ libfilter_la_SOURCES = filter-lexer.l filter-parser.y \
        filter-bytecode.h \
        filter-ir.h \
        memstream.h
+libfilter_la_CFLAGS = -include filter-symbols.h
 
 filter_grammar_test_SOURCES = filter-grammar-test.c
 filter_grammar_test_LDADD = libfilter.la
This page took 0.023054 seconds and 4 git commands to generate.