lib: compile liblttng-ctl as C++
[lttng-tools.git] / src / lib / lttng-ctl / Makefile.am
index e1ffd6a48cf74adb116727fef6b61fecb8a811b0..b31e5bd6f819e79f6b45caa10a659bfe37de4a8a 100644 (file)
@@ -6,10 +6,20 @@ AM_CPPFLAGS += -I$(srcdir) -I$(builddir)
 
 lib_LTLIBRARIES = liblttng-ctl.la
 
-liblttng_ctl_la_SOURCES = lttng-ctl.c snapshot.c lttng-ctl-helper.h \
-               lttng-ctl-health.c save.c load.c deprecated-symbols.c \
-               channel.c rotate.c event.c destruction-handle.c clear.c \
-               tracker.c
+liblttng_ctl_la_SOURCES = \
+               channel.cpp \
+               clear.cpp \
+               deprecated-symbols.cpp \
+               destruction-handle.cpp \
+               event.cpp \
+               load.cpp \
+               lttng-ctl.cpp \
+               lttng-ctl-health.cpp \
+               lttng-ctl-helper.h \
+               rotate.cpp \
+               save.cpp \
+               snapshot.cpp \
+               tracker.cpp
 
 liblttng_ctl_la_LDFLAGS = \
                $(LT_NO_UNDEFINED) \
This page took 0.024127 seconds and 4 git commands to generate.