common: compile libconsumer, libust-consumer, libkernel-consumer as C++
[lttng-tools.git] / src / common / consumer / Makefile.am
index 55e47b2101dcae6ac7ef0c4eab260689c601ba98..ba3ecf1da3834879d9053d409cfee063d57e53d2 100644 (file)
@@ -5,9 +5,15 @@ noinst_LTLIBRARIES = libconsumer.la
 noinst_HEADERS = consumer-metadata-cache.h consumer-timer.h \
                 consumer-testpoint.h
 
-libconsumer_la_SOURCES = consumer.c consumer.h consumer-metadata-cache.c \
-                         consumer-timer.c consumer-stream.c consumer-stream.h \
-                         metadata-bucket.c metadata-bucket.h
+libconsumer_la_SOURCES = \
+       consumer.cpp \
+       consumer.h \
+       consumer-metadata-cache.cpp \
+       consumer-stream.cpp \
+       consumer-stream.h \
+       consumer-timer.cpp \
+       metadata-bucket.cpp \
+       metadata-bucket.h
 
 libconsumer_la_LIBADD = \
                $(top_builddir)/src/common/sessiond-comm/libsessiond-comm.la \
This page took 0.022832 seconds and 4 git commands to generate.