Move libconsumer under common/consumer/
[lttng-tools.git] / src / common / consumer / Makefile.am
diff --git a/src/common/consumer/Makefile.am b/src/common/consumer/Makefile.am
new file mode 100644 (file)
index 0000000..029fb1d
--- /dev/null
@@ -0,0 +1,22 @@
+AM_CPPFLAGS = -I$(top_srcdir)/include -I$(top_srcdir)/src
+
+# Consumer library
+noinst_LTLIBRARIES = libconsumer.la
+
+noinst_HEADERS = consumer-metadata-cache.h consumer-timer.h \
+                consumer-testpoint.h
+
+libconsumer_la_SOURCES = consumer.c consumer.h consumer-metadata-cache.c \
+                         consumer-timer.c consumer-stream.c consumer-stream.h
+
+libconsumer_la_LIBADD = \
+               $(top_builddir)/src/common/sessiond-comm/libsessiond-comm.la \
+               $(top_builddir)/src/common/kernel-consumer/libkernel-consumer.la \
+               $(top_builddir)/src/common/hashtable/libhashtable.la \
+               $(top_builddir)/src/common/compat/libcompat.la \
+               $(top_builddir)/src/common/relayd/librelayd.la
+
+if HAVE_LIBLTTNG_UST_CTL
+libconsumer_la_LIBADD += \
+               $(top_builddir)/src/common/ust-consumer/libust-consumer.la
+endif
This page took 0.02329 seconds and 4 git commands to generate.