common: compile libcompat as C++
[lttng-tools.git] / src / common / compat / Makefile.am
index a8f2c10019afe07e076854a1f24ff2b366c27b24..0499b356824694fb3aab0e13abff5d98affca013 100644 (file)
@@ -2,8 +2,23 @@
 
 noinst_LTLIBRARIES = libcompat.la
 
-libcompat_la_SOURCES = poll.c poll.h fcntl.h endian.h mman.h dirent.h \
-               socket.h compat-fcntl.c tid.h \
-               getenv.h string.h paths.h pthread.h netdb.h \
-               time.h directory-handle.h directory-handle.c path.h \
-               errno.h
+libcompat_la_SOURCES = \
+        compat-fcntl.cpp \
+        directory-handle.cpp \
+        directory-handle.h \
+        dirent.h \
+        endian.h \
+        errno.h \
+        fcntl.h \
+        getenv.h \
+        mman.h \
+        netdb.h \
+        path.h \
+        paths.h \
+        poll.cpp \
+        poll.h \
+        pthread.h \
+        socket.h \
+        string.h \
+        tid.h \
+        time.h
This page took 0.02306 seconds and 4 git commands to generate.