Move event-expr-to-bytecode to event-expr
[lttng-tools.git] / src / common / Makefile.am
index cfb935c5ad2b2dc6d43c088478f95fdbc8002f43..9c66a7658cf170b9cc5690a04a419269ae2ffb11 100644 (file)
@@ -3,10 +3,14 @@
 AUTOMAKE_OPTIONS = subdir-objects
 
 SUBDIRS = \
-       string-utils \
+       argpar \
        bytecode \
+       compat \
+       config \
+       fd-tracker \
+       string-utils \
        filter \
-       argpar
+       hashtable
 
 # Make sure to always distribute all folders
 # since SUBDIRS is decided at configure time.
@@ -35,17 +39,19 @@ EXTRA_DIST = mi-lttng-4.0.xsd
 
 libcommon_la_SOURCES = \
        actions/action.c \
-       actions/group.c \
+       actions/list.c \
        actions/notify.c \
+       actions/path.c \
        actions/rotate-session.c \
        actions/snapshot-session.c \
        actions/start-session.c \
        actions/stop-session.c \
+       actions/rate-policy.c \
        buffer-view.h buffer-view.c \
        common.h \
        conditions/buffer-usage.c \
        conditions/condition.c \
-       conditions/event-rule.c \
+       conditions/event-rule-matches.c \
        conditions/session-consumed-size.c \
        conditions/session-rotation.c \
        context.c context.h \
@@ -57,19 +63,28 @@ libcommon_la_SOURCES = \
        dynamic-buffer.c dynamic-buffer.h \
        endpoint.c \
        error.c error.h \
+       error-query.c \
        evaluation.c \
        event.c \
+       event-expr/event-expr.c \
+       event-field-value.c \
        event-rule/event-rule.c \
-       event-rule/kprobe.c \
-       event-rule/syscall.c \
-       event-rule/uprobe.c \
-       event-rule/tracepoint.c \
+       event-rule/kernel-kprobe.c \
+       event-rule/kernel-syscall.c \
+       event-rule/kernel-uprobe.c \
+       event-rule/kernel-tracepoint.c \
+       event-rule/user-tracepoint.c \
+       event-rule/log4j-logging.c \
+       event-rule/jul-logging.c \
+       event-rule/python-logging.c \
        filter.c filter.h \
        fd-handle.c fd-handle.h \
        fs-handle.c fs-handle.h fs-handle-internal.h \
        futex.c futex.h \
        kernel-probe.c \
+       index-allocator.c index-allocator.h \
        location.c \
+       log-level-rule.c \
        mi-lttng.c mi-lttng.h \
        notification.c \
        optional.h \
@@ -78,6 +93,7 @@ libcommon_la_SOURCES = \
        pipe.c pipe.h \
        readwrite.c readwrite.h \
        runas.c runas.h \
+       shm.c shm.h \
        session-descriptor.c \
        snapshot.c snapshot.h \
        spawn-viewer.c spawn-viewer.h \
@@ -105,20 +121,13 @@ libcommon_la_LIBADD = \
        $(top_builddir)/src/common/compat/libcompat.la \
        $(top_builddir)/src/common/hashtable/libhashtable.la \
        $(top_builddir)/src/common/fd-tracker/libfd-tracker.la \
-       $(top_builddir)/src/common/filter/libfilter.la
-
-if BUILD_LIB_COMPAT
-SUBDIRS += compat
-endif
+       $(top_builddir)/src/common/filter/libfilter.la \
+       $(top_builddir)/src/vendor/msgpack/libmsgpack.la
 
 if BUILD_LIB_HEALTH
 SUBDIRS += health
 endif
 
-if BUILD_LIB_HASHTABLE
-SUBDIRS += hashtable
-endif
-
 if BUILD_LIB_KERNEL_CTL
 SUBDIRS += kernel-ctl
 endif
@@ -131,9 +140,6 @@ if BUILD_LIB_RELAYD
 SUBDIRS += relayd
 endif
 
-if BUILD_LIB_FD_TRACKER
-SUBDIRS += fd-tracker
-endif
 
 if BUILD_LIB_KERNEL_CONSUMER
 SUBDIRS += kernel-consumer
@@ -151,10 +157,6 @@ if BUILD_LIB_INDEX
 SUBDIRS += index
 endif
 
-if BUILD_LIB_CONFIG
-SUBDIRS += config
-endif
-
 if BUILD_LIB_CONSUMER
 SUBDIRS += consumer
 endif
@@ -172,6 +174,11 @@ noinst_HEADERS = \
        uri.h \
        utils.h
 
+noinst_PROGRAMS = filter-grammar-test
+filter_grammar_test_SOURCES = filter-grammar-test.c
+filter_grammar_test_LDADD = \
+       libcommon.la
+
 all-local:
        @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
                for script in $(EXTRA_DIST); do \
This page took 0.02485 seconds and 4 git commands to generate.