Fix: build: libcommon fd-tracker dependency is not available
[lttng-tools.git] / src / common / Makefile.am
index e9bc3d96508d8860a78229deda7498f1bb0482b0..0885448b5dbccb63d53fd32ee05ea4a90f2bf66a 100644 (file)
@@ -3,10 +3,14 @@
 AUTOMAKE_OPTIONS = subdir-objects
 
 SUBDIRS = \
-       string-utils \
+       argpar \
        bytecode \
+       compat \
+       config \
+       fd-tracker \
+       string-utils \
        filter \
-       argpar
+       hashtable
 
 # Make sure to always distribute all folders
 # since SUBDIRS is decided at configure time.
@@ -120,18 +124,10 @@ libcommon_la_LIBADD = \
        $(top_builddir)/src/common/filter/libfilter.la \
        $(top_builddir)/src/vendor/msgpack/libmsgpack.la
 
-if BUILD_LIB_COMPAT
-SUBDIRS += compat
-endif
-
 if BUILD_LIB_HEALTH
 SUBDIRS += health
 endif
 
-if BUILD_LIB_HASHTABLE
-SUBDIRS += hashtable
-endif
-
 if BUILD_LIB_KERNEL_CTL
 SUBDIRS += kernel-ctl
 endif
@@ -144,9 +140,6 @@ if BUILD_LIB_RELAYD
 SUBDIRS += relayd
 endif
 
-if BUILD_LIB_FD_TRACKER
-SUBDIRS += fd-tracker
-endif
 
 if BUILD_LIB_KERNEL_CONSUMER
 SUBDIRS += kernel-consumer
@@ -164,10 +157,6 @@ if BUILD_LIB_INDEX
 SUBDIRS += index
 endif
 
-if BUILD_LIB_CONFIG
-SUBDIRS += config
-endif
-
 if BUILD_LIB_CONSUMER
 SUBDIRS += consumer
 endif
This page took 0.026462 seconds and 4 git commands to generate.