bin: compile lttng-relayd as a C++
[lttng-tools.git] / src / bin / lttng-relayd / Makefile.am
index f6d5b29501f17295dcc9fc1e0e8641b502be6710..51b23296835d1f14e1cd23958033582da5229481 100644 (file)
@@ -9,23 +9,23 @@ endif
 
 bin_PROGRAMS = lttng-relayd
 
-lttng_relayd_SOURCES = main.c lttng-relayd.h utils.h utils.c cmd.h \
-                       index.c index.h live.c live.h ctf-trace.c ctf-trace.h \
-                       cmd-2-1.c cmd-2-1.h \
-                       cmd-2-2.c cmd-2-2.h \
-                       cmd-2-4.c cmd-2-4.h \
-                       cmd-2-11.c cmd-2-11.h \
-                       health-relayd.c health-relayd.h \
+lttng_relayd_SOURCES = main.cpp lttng-relayd.h utils.h utils.cpp cmd.h \
+                       index.cpp index.h live.cpp live.h ctf-trace.cpp ctf-trace.h \
+                       cmd-2-1.cpp cmd-2-1.h \
+                       cmd-2-2.cpp cmd-2-2.h \
+                       cmd-2-4.cpp cmd-2-4.h \
+                       cmd-2-11.cpp cmd-2-11.h \
+                       health-relayd.cpp health-relayd.h \
                        lttng-viewer-abi.h testpoint.h \
-                       viewer-stream.h viewer-stream.c \
-                       session.c session.h \
-                       stream.c stream.h \
-                       connection.c connection.h \
-                       viewer-session.c viewer-session.h \
-                       tracefile-array.c tracefile-array.h \
-                       tcp_keep_alive.c tcp_keep_alive.h \
-                       sessiond-trace-chunks.c sessiond-trace-chunks.h \
-                       backward-compatibility-group-by.c backward-compatibility-group-by.h
+                       viewer-stream.h viewer-stream.cpp \
+                       session.cpp session.h \
+                       stream.cpp stream.h \
+                       connection.cpp connection.h \
+                       viewer-session.cpp viewer-session.h \
+                       tracefile-array.cpp tracefile-array.h \
+                       tcp_keep_alive.cpp tcp_keep_alive.h \
+                       sessiond-trace-chunks.cpp sessiond-trace-chunks.h \
+                       backward-compatibility-group-by.cpp backward-compatibility-group-by.h
 
 # link on liblttngctl for check if relayd is already alive.
 lttng_relayd_LDADD = $(URCU_LIBS) \
This page took 0.02395 seconds and 4 git commands to generate.