Complete change of the source directory tree
[lttng-tools.git] / lttng-sessiond / Makefile.am
diff --git a/lttng-sessiond/Makefile.am b/lttng-sessiond/Makefile.am
deleted file mode 100644 (file)
index 8fcea94..0000000
+++ /dev/null
@@ -1,45 +0,0 @@
-AM_CPPFLAGS = -I$(top_srcdir)/include \
-                         -DINSTALL_BIN_PATH=\""$(bindir)"\" \
-                         -DINSTALL_LIB_PATH=\""$(libdir)"\"
-
-AM_CFLAGS = -fno-strict-aliasing
-
-bin_PROGRAMS = lttng-sessiond
-
-if COMPAT_EPOLL
-COMPAT=compat/compat-epoll.c
-else
-COMPAT=compat/compat-poll.c
-endif
-
-lttng_sessiond_SOURCES = utils.c utils.h \
-                       compat/poll.h $(COMPAT) \
-                       trace-kernel.c trace-kernel.h \
-                       kernel.c kernel.h \
-                       ust-ctl.h ust-app.h trace-ust.h \
-                       context.c context.h \
-                       channel.c channel.h \
-                       event.c event.h \
-                       futex.c futex.h \
-                       shm.c shm.h \
-                       session.c session.h \
-                       lttng-ust-ctl.h lttng-ust-abi.h
-
-if HAVE_LIBLTTNG_UST_CTL
-lttng_sessiond_SOURCES += trace-ust.c ust-app.c ust-consumer.c ust-consumer.h
-endif
-
-# Add main.c at the end for compile order
-lttng_sessiond_SOURCES += lttng-sessiond.h main.c
-
-# link on liblttngctl for check if sessiond is already alive.
-lttng_sessiond_LDADD = -lrt -lurcu-common -lurcu \
-                $(top_builddir)/liblttng-sessiond-comm/liblttng-sessiond-comm.la \
-                $(top_builddir)/libkernelctl/libkernelctl.la \
-                $(top_builddir)/liblttngctl/liblttngctl.la \
-                $(top_builddir)/common/libcommon.la \
-                $(top_builddir)/liblttng-ht/liblttng-ht.la
-
-if HAVE_LIBLTTNG_UST_CTL
-lttng_sessiond_LDADD += -llttng-ust-ctl
-endif
This page took 0.023577 seconds and 4 git commands to generate.