UST 2.0 support
[lttng-tools.git] / lttng-consumerd / Makefile.am
diff --git a/lttng-consumerd/Makefile.am b/lttng-consumerd/Makefile.am
new file mode 100644 (file)
index 0000000..2c1d564
--- /dev/null
@@ -0,0 +1,14 @@
+AM_CPPFLAGS = -I$(top_srcdir)/include
+
+bin_PROGRAMS = lttng-consumerd
+
+lttng_consumerd_SOURCES = lttng-consumerd.c
+
+lttng_consumerd_LDADD = \
+          $(top_builddir)/libkernelctl/libkernelctl.la \
+          $(top_builddir)/liblttng-consumer/liblttng-consumer.la \
+          $(top_builddir)/liblttng-sessiond-comm/liblttng-sessiond-comm.la
+
+if LTTNG_TOOLS_HAVE_UST
+lttng_consumerd_LDADD += -lustctl
+endif
This page took 0.02248 seconds and 4 git commands to generate.