Merge rculfhash into lttng-tools
[lttng-tools.git] / ltt-sessiond / Makefile.am
index e1b42ca09ef6699ed46f31716417d74a55a47b2a..6ee9fa48f9382be23f675382d091488a9a746181 100644 (file)
@@ -6,12 +6,13 @@ AM_CFLAGS = -fno-strict-aliasing
 bin_PROGRAMS = ltt-sessiond
 
 if COMPAT_EPOLL
-COMPAT=compat-epoll.c
+COMPAT=compat/compat-epoll.c
 else
-COMPAT=compat-poll.c
+COMPAT=compat/compat-poll.c
 endif
 
 ltt_sessiond_SOURCES = utils.c utils.h \
+                       compat/poll.h $(COMPAT) \
                        trace-kernel.c trace-kernel.h \
                        trace-ust.c trace-ust.h \
                        traceable-app.c traceable-app.h \
@@ -19,12 +20,13 @@ ltt_sessiond_SOURCES = utils.c utils.h \
                        ust-ctl.c ust-ctl.h \
                        kernel-ctl.c kernel-ctl.h \
                        context.c context.h \
+                       channel.c channel.h \
+                       event.c event.h \
                        futex.c futex.h \
                        shm.c shm.h \
-                       poll.h \
-                       $(COMPAT) \
                        session.c session.h \
-                       ltt-sessiond.h main.c
+                       ltt-sessiond.h main.c \
+                       ../hashtable/rculfhash.c
 
 # link on liblttngctl for check if sessiond is already alive.
 ltt_sessiond_LDADD = -lrt \
This page took 0.02333 seconds and 4 git commands to generate.