Add and support the new hash table library
[lttng-tools.git] / liblttng-ht / Makefile.am
diff --git a/liblttng-ht/Makefile.am b/liblttng-ht/Makefile.am
new file mode 100644 (file)
index 0000000..bd85018
--- /dev/null
@@ -0,0 +1,13 @@
+AM_CPPFLAGS = -I$(top_srcdir)/include
+
+noinst_LTLIBRARIES = liblttng-ht.la
+
+liblttng_ht_la_SOURCES = lttng-ht.c \
+                         utils.c utils.h \
+                         rculfhash-internal.h urcu-flavor.h \
+                         rculfhash.h rculfhash.c \
+                         rculfhash-mm-chunk.c \
+                         rculfhash-mm-mmap.c \
+                         rculfhash-mm-order.c
+
+liblttng_ht_la_LIBADD = -lurcu-common -lurcu
This page took 0.022918 seconds and 4 git commands to generate.