UST 2.0 support
[lttng-tools.git] / liblttng-consumer / Makefile.am
diff --git a/liblttng-consumer/Makefile.am b/liblttng-consumer/Makefile.am
new file mode 100644 (file)
index 0000000..e3aa02a
--- /dev/null
@@ -0,0 +1,15 @@
+AM_CPPFLAGS = -I$(top_srcdir)/include
+
+lib_LTLIBRARIES = liblttng-consumer.la
+
+liblttng_consumer_la_SOURCES = lttng-consumer.c
+
+liblttng_consumer_la_LIBADD = \
+               $(top_builddir)/liblttng-sessiond-comm/liblttng-sessiond-comm.la \
+               $(top_builddir)/liblttng-kconsumer/liblttng-kconsumer.la
+
+
+if LTTNG_TOOLS_HAVE_UST
+liblttng_consumer_la_LIBADD += \
+               $(top_builddir)/liblttng-ustconsumer/liblttng-ustconsumer.la
+endif
This page took 0.023292 seconds and 4 git commands to generate.