Add trigger on event rule matches application example
[lttng-tools.git] / doc / examples / trigger-condition-event-matches / Makefile.am
diff --git a/doc/examples/trigger-condition-event-matches/Makefile.am b/doc/examples/trigger-condition-event-matches/Makefile.am
new file mode 100644 (file)
index 0000000..bace545
--- /dev/null
@@ -0,0 +1,21 @@
+# SPDX-License-Identifier: GPL-2.0-only
+
+AM_CPPFLAGS += -I$(srcdir)
+
+LIBLTTNG_CTL=$(top_builddir)/src/lib/lttng-ctl/liblttng-ctl.la
+dist_noinst_SCRIPTS = demo.sh
+EXTRA_DIST = README.md
+
+if HAVE_LIBLTTNG_UST_CTL
+noinst_PROGRAMS = instrumented-app notification-client
+noinst_LIBRARIES = libtracepoint-trigger-example.a
+
+libtracepoint_trigger_example_a_SOURCES = tracepoint-trigger-example.c tracepoint-trigger-example.h
+
+instrumented_app_SOURCES = instrumented-app.c
+instrumented_app_LDADD = libtracepoint-trigger-example.a $(UST_LIBS) $(DL_LIBS)
+
+notification_client_SOURCES = notification-client.c
+notification_client_LDADD = $(LIBLTTNG_CTL)
+
+endif
This page took 0.023788 seconds and 4 git commands to generate.