use signal safe ust_safe_snprintf()
[ust.git] / ustd / Makefile.am
index f2cb9597c319c0170bd2253eace0dbf29b572066..6adad644b36b0f002a51df336b500d441d178c44 100644 (file)
@@ -1,9 +1,8 @@
+AM_CPPFLAGS = -I$(top_srcdir)/libust -I$(top_srcdir)/libustcomm \
+       -I$(top_srcdir)/include
+
 bin_PROGRAMS = ustd
-ustd_SOURCES = lowlevel.c localerr.h ustd.c ustd.h $(top_builddir)/libustcomm/ustcomm.c $(top_builddir)/libustcomm/ustcomm.h $(top_builddir)/share/kref.c
+ustd_SOURCES = lowlevel.c ustd.c ustd.h $(top_srcdir)/libustcomm/ustcomm.c $(top_srcdir)/libustcomm/ustcomm.h
+ustd_LDADD = $(top_builddir)/snprintf/libustsnprintf.la
 ustd_LDFLAGS = -lpthread
-
-INCLUDES = -I$(top_builddir)/share
-#INCLUDES += -I@URCU_PATH@
-INCLUDES += -I@KCOMPAT_PATH@
-INCLUDES += -I$(top_builddir)/libust
-INCLUDES += -I$(top_builddir)/libustcomm
+ustd_CFLAGS = -DUST_COMPONENT=ustd
This page took 0.023428 seconds and 4 git commands to generate.