compile with -fno-strict-aliasing
[ust.git] / ustd / Makefile.am
index df49a82083e4f81e56614ab14accd60ac3c950ae..09d098488e10d39eb736b0b0bfbfaed4bdd380d9 100644 (file)
@@ -1,7 +1,14 @@
-INCLUDES = -I$(top_builddir)/share -I$(top_builddir)/libust \
-        -I$(top_builddir)/libustcomm
+AM_CPPFLAGS = -I$(top_srcdir)/libust -I$(top_srcdir)/libustcomm \
+       -I$(top_srcdir)/include
+AM_CFLAGS = -fno-strict-aliasing
 
 bin_PROGRAMS = ustd
-ustd_SOURCES = lowlevel.c ustd.c ustd.h $(top_builddir)/libustcomm/ustcomm.c $(top_builddir)/libustcomm/ustcomm.h $(top_builddir)/share/usterr.h
+
+ustd_SOURCES = lowlevel.c ustd.c ustd.h
+
+ustd_LDADD = \
+       $(top_builddir)/snprintf/libustsnprintf.la \
+       $(top_builddir)/libustcomm/libustcomm.la
+
 ustd_LDFLAGS = -lpthread
-ustd_CFLAGS = -DUST_COMPONENT=ustd
+ustd_CFLAGS = -DUST_COMPONENT=ustd -fno-strict-aliasing
This page took 0.022957 seconds and 4 git commands to generate.