compile with -fno-strict-aliasing
[ust.git] / ustd / Makefile.am
index c4b156723b045e377f36f425f797bdfa072a4af9..09d098488e10d39eb736b0b0bfbfaed4bdd380d9 100644 (file)
@@ -1,7 +1,14 @@
 AM_CPPFLAGS = -I$(top_srcdir)/libust -I$(top_srcdir)/libustcomm \
        -I$(top_srcdir)/include
+AM_CFLAGS = -fno-strict-aliasing
 
 bin_PROGRAMS = ustd
-ustd_SOURCES = lowlevel.c ustd.c ustd.h $(top_srcdir)/libustcomm/ustcomm.c $(top_srcdir)/libustcomm/ustcomm.h
+
+ustd_SOURCES = lowlevel.c ustd.c ustd.h
+
+ustd_LDADD = \
+       $(top_builddir)/snprintf/libustsnprintf.la \
+       $(top_builddir)/libustcomm/libustcomm.la
+
 ustd_LDFLAGS = -lpthread
-ustd_CFLAGS = -DUST_COMPONENT=ustd
+ustd_CFLAGS = -DUST_COMPONENT=ustd -fno-strict-aliasing
This page took 0.02267 seconds and 4 git commands to generate.