compile with -fno-strict-aliasing
[ust.git] / ustd / Makefile.am
index 8c8fe647ab328b67d06069c39df1a1e86c9d9cae..09d098488e10d39eb736b0b0bfbfaed4bdd380d9 100644 (file)
@@ -1,7 +1,14 @@
-AM_CPPFLAGS = -I$(top_builddir)/libust -I$(top_builddir)/libustcomm \
-       -I$(top_builddir)/include
+AM_CPPFLAGS = -I$(top_srcdir)/libust -I$(top_srcdir)/libustcomm \
+       -I$(top_srcdir)/include
+AM_CFLAGS = -fno-strict-aliasing
 
 bin_PROGRAMS = ustd
-ustd_SOURCES = lowlevel.c ustd.c ustd.h $(top_builddir)/libustcomm/ustcomm.c $(top_builddir)/libustcomm/ustcomm.h
+
+ustd_SOURCES = lowlevel.c ustd.c ustd.h
+
+ustd_LDADD = \
+       $(top_builddir)/snprintf/libustsnprintf.la \
+       $(top_builddir)/libustcomm/libustcomm.la
+
 ustd_LDFLAGS = -lpthread
-ustd_CFLAGS = -DUST_COMPONENT=ustd
+ustd_CFLAGS = -DUST_COMPONENT=ustd -fno-strict-aliasing
This page took 0.022272 seconds and 4 git commands to generate.