compile with -fno-strict-aliasing
[ust.git] / ustd / Makefile.am
index 723b9dfe40843e06926baf9b55acdfd1efc57438..09d098488e10d39eb736b0b0bfbfaed4bdd380d9 100644 (file)
@@ -1,9 +1,14 @@
+AM_CPPFLAGS = -I$(top_srcdir)/libust -I$(top_srcdir)/libustcomm \
+       -I$(top_srcdir)/include
+AM_CFLAGS = -fno-strict-aliasing
+
 bin_PROGRAMS = ustd
-ustd_SOURCES = lowlevel.c localerr.h ustd.c ustd.h $(top_builddir)/libustcomm/ustcomm.c $(top_builddir)/libustcomm/ustcomm.h $(top_builddir)/share/kref.c
-ustd_LDFLAGS = -lpthread
 
-INCLUDES = -I$(top_builddir)/share
-INCLUDES += -I@URCU_PATH@
-INCLUDES += -I@KCOMPAT_PATH@
-INCLUDES += -I$(top_builddir)/libust
-INCLUDES += -I$(top_builddir)/libustcomm
+ustd_SOURCES = lowlevel.c ustd.c ustd.h
+
+ustd_LDADD = \
+       $(top_builddir)/snprintf/libustsnprintf.la \
+       $(top_builddir)/libustcomm/libustcomm.la
+
+ustd_LDFLAGS = -lpthread
+ustd_CFLAGS = -DUST_COMPONENT=ustd -fno-strict-aliasing
This page took 0.022503 seconds and 4 git commands to generate.