Update version to 0.16
[ust.git] / snprintf / Makefile.am
index 1bd33fa429efb6ef9c139a91ff3ec15e8e51a031..efa35340540df66972ddb829daa46594a72dde3a 100644 (file)
@@ -1,6 +1,7 @@
 AM_CPPFLAGS = -I$(top_srcdir)/include -I$(top_srcdir)/libustcomm
+AM_CFLAGS = -fno-strict-aliasing
 
-lib_LTLIBRARIES = libustsnprintf.la
+noinst_LTLIBRARIES = libustsnprintf.la
 libustsnprintf_la_SOURCES = \
        fflush.c \
        fileext.h \
@@ -8,15 +9,11 @@ libustsnprintf_la_SOURCES = \
        fvwrite.c \
        fvwrite.h \
        local.h \
+       mbrtowc_sb.c \
        snprintf.c \
        various.h \
        vfprintf.c \
        wcio.h \
        wsetup.c
-libustsnprintf_la_LDFLAGS = -no-undefined -version-info 0:0:0 -static
-libustsnprintf_la_CFLAGS = -DUST_COMPONENT="ust_snprintf" -fPIC
-
-check_PROGRAMS = prog
-prog_SOURCES = prog.c
-prog_LDADD = libustsnprintf.la
-TESTS = prog
+libustsnprintf_la_LDFLAGS = -no-undefined -static
+libustsnprintf_la_CFLAGS = -DUST_COMPONENT="ust_snprintf" -fPIC -fno-strict-aliasing
This page took 0.022484 seconds and 4 git commands to generate.