don't install libustcomm and libustsnprintf
[ust.git] / libustcomm / Makefile.am
index fa24cfb133bd94f514b410617634ef3e1b25cae7..2672071e2f953f61c34e44802a05c356e5da69d5 100644 (file)
@@ -1,8 +1,11 @@
 AM_CPPFLAGS = -I$(top_srcdir)/include
+AM_CFLAGS = -fno-strict-aliasing
 
-lib_LTLIBRARIES = libustcomm.la
+noinst_LTLIBRARIES = libustcomm.la
 libustcomm_la_SOURCES = \
        ustcomm.h \
-       ustcomm.c
-libustcomm_la_LDFLAGS = -no-undefined -version-info 0:0:0 -static
-libustcomm_la_CFLAGS = -DUST_COMPONENT="libustcomm" -fPIC
+       ustcomm.c \
+       multipoll.h \
+       multipoll.c
+libustcomm_la_LDFLAGS = -no-undefined -static
+libustcomm_la_CFLAGS = -DUST_COMPONENT="libustcomm" -fPIC -fno-strict-aliasing
This page took 0.022767 seconds and 4 git commands to generate.