Make buildsystem use pkg-config to search for kcompat and liburcu
[ust.git] / hello / Makefile.am
index 3c96bee3c7b57de66f3af74d9f5013c67b08af14..85b04b6679c23913a7421c62fa164eddb0f01755 100644 (file)
@@ -1,7 +1,6 @@
-lib_LTLIBRARIES = libmarkers.la
-libmarkers_la_SOURCES = marker.c tracepoint.c immediate.h jhash.h rcupdate.h marker.h tracepoint.h
+INCLUDES = -I$(top_builddir)/share -I$(top_builddir)/libust \
+       $(KCOMPAT_CFLAGS) $(URCU_CFLAGS)
 
-INCLUDES = -I$(top_builddir)/share
-INCLUDES += -I@URCU_PATH@
-INCLUDES += -I@KCOMPAT_PATH@
-INCLUDES += -I$(top_builddir)/libtracing
+noinst_PROGRAMS = hello
+hello_SOURCES = hello.c tp.c tp.h
+hello_LDADD = $(top_builddir)/libust/libust.la $(URCU_LIBS)
This page took 0.022669 seconds and 4 git commands to generate.