Make buildsystem use pkg-config to search for kcompat and liburcu
[ust.git] / hello / Makefile.am
index 2a4e6b7d02602af601030651fba84dc8d0e03f16..85b04b6679c23913a7421c62fa164eddb0f01755 100644 (file)
@@ -1,8 +1,6 @@
-bin_PROGRAMS = hello
-hello_SOURCES = hello.c tp.c tp.h
-hello_LDADD = $(top_builddir)/libust/libust.la @URCU_PATH@/liburcu.so
+INCLUDES = -I$(top_builddir)/share -I$(top_builddir)/libust \
+       $(KCOMPAT_CFLAGS) $(URCU_CFLAGS)
 
-INCLUDES = -I$(top_builddir)/share
-INCLUDES += -I@URCU_PATH@
-INCLUDES += -I@KCOMPAT_PATH@
-INCLUDES += -I$(top_builddir)/libust
+noinst_PROGRAMS = hello
+hello_SOURCES = hello.c tp.c tp.h
+hello_LDADD = $(top_builddir)/libust/libust.la $(URCU_LIBS)
This page took 0.021892 seconds and 4 git commands to generate.