Fix: Don't override user variables within the build system
[urcu.git] / tests / utils / Makefile.am
index 24c0bb87942600b6fb26879578e0485af4d92f8d..31d7913e2d4864b2f04443e6afaf613e288192ca 100644 (file)
@@ -1,3 +1,22 @@
+AM_CFLAGS += -I$(top_srcdir)/include -I$(top_builddir)/include -I$(top_srcdir)/src
+
 noinst_LIBRARIES = libtap.a
 libtap_a_SOURCES = tap.c tap.h
 noinst_LIBRARIES = libtap.a
 libtap_a_SOURCES = tap.c tap.h
-dist_noinst_SCRIPTS = tap.sh
+
+SCRIPT_LIST = tap.sh
+
+dist_noinst_SCRIPTS = $(SCRIPT_LIST)
+
+all-local:
+       @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
+               for script in $(SCRIPT_LIST); do \
+                       cp -f $(srcdir)/$$script $(builddir); \
+               done; \
+       fi
+
+clean-local:
+       @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
+               for script in $(SCRIPT_LIST); do \
+                       rm -f $(builddir)/$$script; \
+               done; \
+       fi
This page took 0.024758 seconds and 4 git commands to generate.