Make urcu/config.h work.
[urcu.git] / tests / Makefile.am
index 983ee6777890819ced85bc519aae9b30f8e91266..748e77019d6987c9927194144fbc7300c86ec8ba 100644 (file)
@@ -1,5 +1,5 @@
 AM_LDFLAGS=-lpthread
-AM_CFLAGS=-I$(top_srcdir)
+AM_CFLAGS=-I$(top_srcdir) -I$(top_builddir)
 
 noinst_PROGRAMS = test_urcu test_urcu_dynamic_link test_urcu_timing \
         test_rwlock_timing test_rwlock test_perthreadlock_timing \
@@ -14,11 +14,15 @@ noinst_PROGRAMS = test_urcu test_urcu_dynamic_link test_urcu_timing \
 noinst_HEADERS = rcutorture.h
 
 if COMPAT_ARCH
-COMPAT=$(top_builddir)/compat_arch_@ARCHTYPE@.c
+COMPAT=$(top_srcdir)/compat_arch_@ARCHTYPE@.c
 else
 COMPAT=
 endif
 
+if COMPAT_FUTEX
+COMPAT+=$(top_srcdir)/compat_futex.c
+endif
+
 URCU_SIGNAL=$(top_builddir)/urcu.c $(top_builddir)/urcu-pointer.c $(COMPAT)
 # URCU_SIGNAL_YIELD uses urcu.c but -DDEBUG_YIELD must be defined
 URCU_SIGNAL_YIELD=$(top_builddir)/urcu.c $(top_builddir)/urcu-pointer.c $(COMPAT)
This page took 0.022815 seconds and 4 git commands to generate.