doc/examples: automake stop on error
[urcu.git] / doc / examples / Makefile.am
index d516bb6b1a51b5c74bdd49f52698df5e2779911c..d48686484930418cd4162970f21d1f643bcc8fd1 100644 (file)
@@ -80,11 +80,11 @@ SUBDIRS_PROXY = qsbr-minimal list hlist wfcqueue wfstack lfstack
 
 all-local:
        for subdir in $(SUBDIRS_PROXY); do \
-               cd $$subdir && $(MAKE) AM_CPPFLAGS="-I../../../urcu/ -I../../../" AM_LDFLAGS='-L../../../.libs/ -Wl,-rpath="$(PWD)/../../.libs/"' $(AM_MAKEFLAGS) all; cd ..; \
+               cd $$subdir && $(MAKE) AM_CPPFLAGS="-I../../../urcu/ -I../../../" AM_LDFLAGS='-L../../../.libs/ -Wl,-rpath="$(PWD)/../../.libs/"' $(AM_MAKEFLAGS) all && cd ..; \
        done
 
 clean-local:
        for subdir in $(SUBDIRS_PROXY); do \
-               cd $$subdir && $(MAKE) $(AM_MAKEFLAGS) clean; cd ..; \
+               cd $$subdir && $(MAKE) $(AM_MAKEFLAGS) clean && cd ..; \
        done
 endif
This page took 0.022302 seconds and 4 git commands to generate.