doc/examples: rename qsbr-minimal to rcu-flavor-qsbr
[urcu.git] / doc / examples / Makefile.am
index 5c3e76f82a13a5e924392979a2c53cfcc265ae4a..acdaaac1d9f2583b2fbf3c3aafded2b82761a116 100644 (file)
@@ -1,10 +1,10 @@
 doc_examplesdir = ${docdir}/examples
 
-doc_examples_qsbr_minimaldir = ${doc_examplesdir}/qsbr-minimal
+doc_examples_rcu_flavor_qsbrdir = ${doc_examplesdir}/rcu-flavor-qsbr
 
-dist_doc_examples_qsbr_minimal_DATA = \
-       qsbr-minimal/Makefile \
-       qsbr-minimal/qsbr-minimal.c
+dist_doc_examples_rcu_flavor_qsbr_DATA = \
+       rcu-flavor-qsbr/Makefile \
+       rcu-flavor-qsbr/rcu-flavor-qsbr.c
 
 dist_doc_examples_DATA = \
        Makefile.examples.template
@@ -26,6 +26,19 @@ dist_doc_examples_list_DATA = \
        list/cds_list_for_each_entry_rcu.c \
        list/cds_list_replace_rcu.c
 
+doc_examples_hlistdir = ${doc_examplesdir}/hlist
+
+dist_doc_examples_hlist_DATA = \
+       hlist/Makefile \
+       hlist/Makefile.cds_hlist_add_head_rcu \
+       hlist/Makefile.cds_hlist_del_rcu \
+       hlist/Makefile.cds_hlist_for_each_rcu \
+       hlist/Makefile.cds_hlist_for_each_entry_rcu \
+       hlist/cds_hlist_add_head_rcu.c \
+       hlist/cds_hlist_del_rcu.c \
+       hlist/cds_hlist_for_each_rcu.c \
+       hlist/cds_hlist_for_each_entry_rcu.c
+
 doc_examples_wfcqueuedir = ${doc_examplesdir}/wfcqueue
 
 dist_doc_examples_wfcqueue_DATA = \
@@ -48,19 +61,30 @@ dist_doc_examples_wfstack_DATA = \
        wfstack/cds_wfs_pop.c \
        wfstack/cds_wfs_pop_all_blocking.c
 
+doc_examples_lfstackdir = ${doc_examplesdir}/lfstack
+
+dist_doc_examples_lfstack_DATA = \
+       lfstack/Makefile \
+       lfstack/Makefile.cds_lfs_push \
+       lfstack/Makefile.cds_lfs_pop_blocking \
+       lfstack/Makefile.cds_lfs_pop_all_blocking \
+       lfstack/cds_lfs_push.c \
+       lfstack/cds_lfs_pop_blocking.c \
+       lfstack/cds_lfs_pop_all_blocking.c
+
 if NO_SHARED
 # Don't build examples if shared libraries support was explicitly
 # disabled.
 else
-SUBDIRS_PROXY = qsbr-minimal list wfcqueue wfstack
+SUBDIRS_PROXY = rcu-flavor-qsbr list hlist wfcqueue wfstack lfstack
 
 all-local:
        for subdir in $(SUBDIRS_PROXY); do \
-               cd $$subdir && $(MAKE) AM_CPPFLAGS="-I../../../urcu/ -I../../../" AM_LDFLAGS='-L../../../.libs/ -Wl,-rpath="$(PWD)/../../.libs/"' $(AM_MAKEFLAGS) all; cd ..; \
+               cd $$subdir && $(MAKE) AM_CPPFLAGS="-I../../../urcu/ -I../../../" AM_LDFLAGS='-L../../../.libs/ -Wl,-rpath="$(PWD)/../../.libs/"' $(AM_MAKEFLAGS) all && cd ..; \
        done
 
 clean-local:
        for subdir in $(SUBDIRS_PROXY); do \
-               cd $$subdir && $(MAKE) $(AM_MAKEFLAGS) clean; cd ..; \
+               cd $$subdir && $(MAKE) $(AM_MAKEFLAGS) clean && cd ..; \
        done
 endif
This page took 0.023171 seconds and 4 git commands to generate.