Fix: examples make distcheck failure
[urcu.git] / doc / examples / Makefile.am
index 3ae68429a25e06822b0999af01e520b652853de3..6828eee1e9c2b96c38676fd49c9e7f8720633abc 100644 (file)
@@ -123,19 +123,22 @@ SUBDIRS_PROXY = hlist list urcu-flavors wfcqueue rculfqueue \
 all-local:
        @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
                cp -pfR $(srcdir)/dist-files $(builddir); \
+               chmod -R u+w $(builddir)/dist-files; \
                cp -pf $(srcdir)/Makefile.examples.template $(builddir); \
+               chmod u+w $(builddir)/Makefile.examples.template; \
                for subdir in $(SUBDIRS_PROXY); do \
                        cp -pfR $(srcdir)/$$subdir $(builddir); \
+                       chmod -R u+w $(builddir)/$$subdir; \
                done; \
        fi; \
-       if [ x"$(shell echo "$(top_srcdir)" | grep "^/" | wc -l)" = x"1" ]; then \
+       if [ x"$(shell echo "$(top_srcdir)" | $(GREP) "^/" | wc -l)" = x"1" ]; then \
                echo "Examples: absolute top_srcdir path $(top_srcdir)"; \
                rel_src_subdir=""; \
        else \
                echo "Examples: relative top_srcdir path $(top_srcdir)"; \
                rel_src_subdir="../"; \
        fi; \
-       if [ x"$(shell echo "$(top_builddir)" | grep "^/" | wc -l)" = x"1" ]; then \
+       if [ x"$(shell echo "$(top_builddir)" | $(GREP) "^/" | wc -l)" = x"1" ]; then \
                echo "Examples: absolute top_builddir path $(top_builddir)"; \
                rel_build_subdir=""; \
        else \
This page took 0.022463 seconds and 4 git commands to generate.