Port: Fixes to build system for portability
[urcu.git] / doc / examples / Makefile.am
index 00ac7e9cc7856723fd1581e14d9e19fc366d3647..313f5215b254f908eeab9502f455ef67ef3a41b6 100644 (file)
@@ -82,13 +82,75 @@ dist_doc_examples_lfstack_DATA = \
        lfstack/cds_lfs_pop_blocking.c \
        lfstack/cds_lfs_pop_all_blocking.c
 
+doc_examples_rculfqueuedir = ${doc_examplesdir}/rculfqueue
+
+dist_doc_examples_rculfqueue_DATA = \
+       rculfqueue/Makefile \
+       rculfqueue/Makefile.cds_lfq_enqueue \
+       rculfqueue/Makefile.cds_lfq_dequeue \
+       rculfqueue/cds_lfq_enqueue.c \
+       rculfqueue/cds_lfq_dequeue.c
+
+doc_examples_rculfhashdir = ${doc_examplesdir}/rculfhash
+
+dist_doc_examples_rculfhash_DATA = \
+       rculfhash/Makefile \
+       rculfhash/jhash.h \
+       rculfhash/Makefile.cds_lfht_add \
+       rculfhash/Makefile.cds_lfht_add_unique \
+       rculfhash/Makefile.cds_lfht_add_replace \
+       rculfhash/Makefile.cds_lfht_del \
+       rculfhash/Makefile.cds_lfht_destroy \
+       rculfhash/Makefile.cds_lfht_lookup \
+       rculfhash/Makefile.cds_lfht_for_each_entry_duplicate \
+       rculfhash/cds_lfht_add.c \
+       rculfhash/cds_lfht_add_unique.c \
+       rculfhash/cds_lfht_add_replace.c \
+       rculfhash/cds_lfht_del.c \
+       rculfhash/cds_lfht_destroy.c \
+       rculfhash/cds_lfht_lookup.c \
+       rculfhash/cds_lfht_for_each_entry_duplicate.c
+
 if NO_SHARED
 # Don't build examples if shared libraries support was explicitly
 # disabled.
 else
+
+SUBDIRS_PROXY = hlist list urcu-flavors wfcqueue rculfqueue \
+       wfstack lfstack rculfhash
+
+# Copies are for VPATH build support.
 all-local:
-       $(MAKE) -f dist-files/Makefile AM_CPPFLAGS="-I../../../urcu/ -I../../../" AM_LDFLAGS='-L../../../.libs/ -Wl,-rpath="$(PWD)/../../.libs/"' $(AM_MAKEFLAGS) all
+       @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
+               cp -pfR $(srcdir)/dist-files $(builddir); \
+               cp -pf $(srcdir)/Makefile.examples.template $(builddir); \
+               for subdir in $(SUBDIRS_PROXY); do \
+                       cp -pfR $(srcdir)/$$subdir $(builddir); \
+               done; \
+       fi; \
+       if [ x"$(shell echo "$(top_srcdir)" | $(GREP) "^/" | wc -l)" = x"1" ]; then \
+               echo "Examples: absolute top_srcdir path $(top_srcdir)"; \
+               rel_src_subdir=""; \
+       else \
+               echo "Examples: relative top_srcdir path $(top_srcdir)"; \
+               rel_src_subdir="../"; \
+       fi; \
+       if [ x"$(shell echo "$(top_builddir)" | $(GREP) "^/" | wc -l)" = x"1" ]; then \
+               echo "Examples: absolute top_builddir path $(top_builddir)"; \
+               rel_build_subdir=""; \
+       else \
+               echo "Examples: relative top_builddir path $(top_builddir)"; \
+               rel_build_subdir="../"; \
+       fi; \
+       $(MAKE) -f dist-files/Makefile AM_CC="$(CC)" AM_CPPFLAGS="$(CPPFLAGS) -I$$rel_src_subdir/$(top_srcdir)/ -I$$rel_build_subdir$(top_builddir)/" AM_CFLAGS='$(CFLAGS)' AM_LDFLAGS='$(LDFLAGS) -L../../../.libs/ -Wl,-rpath "$(PWD)/../../.libs/"' $(AM_MAKEFLAGS) all;
 
 clean-local:
-       $(MAKE) -f dist-files/Makefile $(AM_MAKEFLAGS) clean;
+       @$(MAKE) -f dist-files/Makefile $(AM_MAKEFLAGS) clean; \
+       if [ x"$(srcdir)" != x"$(builddir)" ]; then \
+               for subdir in $(SUBDIRS_PROXY); do \
+                       rm -rf $(builddir)/$$subdir; \
+               done; \
+               rm -f $(builddir)/Makefile.examples.template; \
+               rm -rf $(builddir)/dist-files; \
+       fi;
 endif
This page took 0.022782 seconds and 4 git commands to generate.