Reimplemented build option into new repo.
[lttv.git] / lttv / lttv / Makefile.am
index 944d5988132eb518284a88040c5806bef5fd9cc0..e63f4d7f66e309af74dce57dae472396f9cb3eaf 100644 (file)
@@ -3,9 +3,19 @@ LDADD = $(POPT_LIBS) ${top_builddir}/ltt/liblttvtraceread.la
 
 bin_PROGRAMS = lttv.real
 
+if BUILD_LTTV_GUI
 bin_SCRIPTS = lttv lttv-gui
+else
+bin_SCRIPTS = lttv
+endif
+
 CLEANFILES = $(bin_SCRIPTS)
+
+if BUILD_LTTV_GUI
 EXTRA_DIST = lttv.sh lttv-gui.sh
+else
+EXTRA_DIST = lttv.sh
+endif
 
 lttv: lttv.sh
        rm -f lttv
@@ -45,6 +55,6 @@ lttv_real_SOURCES = batchtest.c main.c module.c option.c \
 lttv_real_LDFLAGS = -export-dynamic
 
 if LTTVSTATIC
-  lttv_real_LDFLAGS += -profile -static
+  lttv_real_LDFLAGS += -static
 endif
 
This page took 0.021916 seconds and 4 git commands to generate.