fix sync with last babeltrace updates to live handling
[lttngtop.git] / src / Makefile.am
index f25868f96136fc1a23134680618bf0cfe379130f..72599e22c25e524db40e5efb5c95b8407d38f735 100644 (file)
@@ -1,4 +1,9 @@
-AM_CFLAGS = $(PACKAGE_CFLAGS)
+AM_CFLAGS = $(PACKAGE_CFLAGS) -I$(top_srcdir)/lib -DBABELTRACE_HAVE_LIBUUID
+
+lib_LTLIBRARIES = libbabeltrace-lttngtop-live.la
+
+libbabeltrace_lttngtop_live_la_SOURCES = \
+                                     network-live.c lttng-live-comm.c
 
 bin_PROGRAMS = lttngtop
 
@@ -7,13 +12,24 @@ noinst_HEADERS = \
        common.h \
        cputop.h \
        cursesdisplay.h \
-       iostreamtop.h
+       iostreamtop.h \
+       mmap-live.h \
+       network-live.h \
+       lttng-live-comm.h \
+       lttng-viewer-abi.h \
+       lttngtop.h
 
 lttngtop_SOURCES = \
        lttngtop.c \
        common.c \
        cursesdisplay.c \
        cputop.c \
-       iostreamtop.c
+       iostreamtop.c \
+       mmap-live.c
+
+lttngtop_LDFLAGS = -Wl,--no-as-needed
+
+#lttngtop_LDADD = -lbabeltrace -lbabeltrace-ctf -llttngtop-helper -llttng-ctl -lurcu -llttngtopmmappacketseek -llttng-ust-ctl -lcurses -lpanel
+lttngtop_LDADD = -lbabeltrace -lbabeltrace-ctf -llttng-ctl -lurcu -llttng-ust-ctl -lcurses -lpanel \
+                $(top_builddir)/src/libbabeltrace-lttngtop-live.la
 
-lttngtop_LDADD = -lbabeltrace -lbabeltrace-ctf -llttngtop-helper -llttng-ctl -lurcu -llttngtopmmappacketseek
This page took 0.022702 seconds and 4 git commands to generate.