Remove broken page up/down support
[lttngtop.git] / configure.ac
index 495a5e07edefdd0dc98cd1f14607f549d7016c54..0b67fc9dd5b7699e2634ca1c08205ebb613109e2 100644 (file)
@@ -50,6 +50,16 @@ AC_CHECK_LIB([panel], [update_panels], [],
        [AC_MSG_ERROR([Cannot find the the ncurses library.])]
 )
 
+# Check for libbabeltrace
+AC_CHECK_LIB([babeltrace], [bt_context_create], [],
+            [AC_MSG_ERROR([Cannot find the babeltrace library.])]
+            )
+
+# Check for libbabeltrace-ctf
+AC_CHECK_LIB([babeltrace-ctf], [bt_ctf_iter_create], [],
+            [AC_MSG_ERROR([Cannot find the babeltrace-ctf library.])]
+            )
+
 # Check for Glib. It needs to be installed anyway or this macro will not be defined.
 AM_PATH_GLIB_2_0([2.22.0], [],
        [AC_MSG_ERROR([Glib 2.22 is required in order to compile LTTngTop.
This page took 0.029507 seconds and 4 git commands to generate.