Detect and document dependency on -ldl on Linux, -lc on BSD for dlopen
[lttng-ust.git] / tests / demo / Makefile.am
index f96980ed6514ae91d2a0024011282de573c41f39..e4570ff0a694d9fea50f14f5ed8e89696832e7a1 100644 (file)
@@ -33,5 +33,11 @@ liblttng_ust_provider_ust_tests_demo3_la_LDFLAGS = \
 
 noinst_PROGRAMS = demo
 demo_SOURCES = demo.c ust_tests_demo.h
-# The demo program only depends on libdl.
-demo_LDFLAGS = -ldl
+# The demo program only depends on libdl/libc for dlopen().
+if LTTNG_UST_BUILD_WITH_LIBDL
+demo_LDADD = -ldl
+endif
+if LTTNG_UST_BUILD_WITH_LIBC_DL
+demo_LDADD = -lc
+endif
+
This page took 0.022906 seconds and 4 git commands to generate.