Add abi0 conflict tests
[lttng-ust.git] / tests / Makefile.am
index b2c1c2b51e4cc96105a6b59c5b598640512caee6..d750ae391ac7309034ae631fa5391100b11b0375 100644 (file)
@@ -1,6 +1,6 @@
 # SPDX-License-Identifier: LGPL-2.1-only
 
-SUBDIRS = utils unit compile benchmark
+SUBDIRS = utils unit compile benchmark regression
 
 LOG_DRIVER_FLAGS = --merge --comments
 LOG_DRIVER = env AM_TAP_AWK='$(AWK)' \
@@ -8,6 +8,8 @@ LOG_DRIVER = env AM_TAP_AWK='$(AWK)' \
        UST_TESTS_BUILDDIR='$(abs_top_builddir)/tests' \
        $(SHELL) $(srcdir)/utils/tap-driver.sh
 
+# Unit tests
+
 TESTS = \
        unit/libringbuffer/test_shm \
        unit/gcc-weak-hidden/test_gcc_weak_hidden \
@@ -23,6 +25,11 @@ TESTS += \
        unit/ust-utils/test_ust_utils_cxx
 endif
 
+# Regression tests
+
+TESTS += \
+       regression/abi0-conflict/test_abi0_conflict
+
 EXTRA_DIST = README
 
 check-loop:
This page took 0.023214 seconds and 4 git commands to generate.