Make futex compat internal to liblttng-ust
[lttng-ust.git] / src / common / Makefile.am
index ff2cfd71bfa6e47dda5f101eac972d5310dfb8a4..f4c134a704685a0358eec114834c91d4878ec090 100644 (file)
@@ -12,15 +12,17 @@ noinst_HEADERS = \
        bitmap.h \
        clock.h \
        creds.h \
-       dynamic-type.h \
-       elf.h \
+       err-ptr.h \
        events.h \
+       hash.h \
        jhash.h \
        logging.h \
        macros.h \
+       ns.h \
        patient.h \
        procname.h \
        safe-snprintf.h \
+       tracepoint.h \
        wait.h
 
 noinst_HEADERS += \
@@ -47,7 +49,6 @@ noinst_HEADERS += \
 
 noinst_LTLIBRARIES = \
        libcounter.la \
-       libcompat.la \
        libmsgpack.la \
        libringbuffer.la \
        libsnprintf.la \
@@ -65,9 +66,7 @@ libcounter_la_SOURCES = \
        counter/shm.c \
        counter/shm.h \
        counter/shm_internal.h \
-       counter/shm_types.h \
-       counter/smp.c \
-       counter/smp.h
+       counter/shm_types.h
 
 libcounter_la_LIBADD = -lrt
 
@@ -77,11 +76,6 @@ endif
 
 libcounter_la_CFLAGS = -DUST_COMPONENT="libcounter" $(AM_CFLAGS)
 
-# compat
-libcompat_la_SOURCES = \
-       compat/futex.c \
-       compat/futex.h
-
 # msgpack
 libmsgpack_la_SOURCES = \
        msgpack/msgpack.c \
@@ -108,8 +102,6 @@ libringbuffer_la_SOURCES = \
        ringbuffer/shm.h \
        ringbuffer/shm_internal.h \
        ringbuffer/shm_types.h \
-       ringbuffer/smp.c \
-       ringbuffer/smp.h \
        ringbuffer/vatomic.h
 
 libringbuffer_la_LIBADD = \
@@ -138,14 +130,24 @@ libsnprintf_la_SOURCES = \
 
 # Common library
 libcommon_la_SOURCES = \
+       dynamic-type.c \
+       dynamic-type.h \
+       elf.c \
+       elf.h \
+       events.c \
        getenv.c \
        getenv.h \
        logging.c \
        logging.h \
+       smp.c \
+       smp.h \
+       strutils.c \
+       strutils.h \
+       utils.c \
+       utils.h \
        patient.c
 
 libcommon_la_LIBADD = \
-       libcompat.la \
        libmsgpack.la \
        libsnprintf.la
 
This page took 0.026275 seconds and 4 git commands to generate.