Make futex compat internal to liblttng-ust
[lttng-ust.git] / src / common / Makefile.am
index fa2a9da87a491cb1a7cdb586bba2816684c96f00..f4c134a704685a0358eec114834c91d4878ec090 100644 (file)
@@ -10,13 +10,20 @@ noinst_HEADERS = \
        align.h \
        bitfield.h \
        bitmap.h \
-       dynamic-type.h \
-       elf.h \
+       clock.h \
+       creds.h \
+       err-ptr.h \
+       events.h \
+       hash.h \
+       jhash.h \
        logging.h \
        macros.h \
+       ns.h \
        patient.h \
        procname.h \
-       safe-snprintf.h
+       safe-snprintf.h \
+       tracepoint.h \
+       wait.h
 
 noinst_HEADERS += \
        compat/dlfcn.h \
@@ -42,9 +49,9 @@ noinst_HEADERS += \
 
 noinst_LTLIBRARIES = \
        libcounter.la \
-       msgpack/libmsgpack.la \
+       libmsgpack.la \
        libringbuffer.la \
-       snprintf/libsnprintf.la \
+       libsnprintf.la \
        libcommon.la \
        libustcomm.la
 
@@ -59,9 +66,7 @@ libcounter_la_SOURCES = \
        counter/shm.c \
        counter/shm.h \
        counter/shm_internal.h \
-       counter/shm_types.h \
-       counter/smp.c \
-       counter/smp.h
+       counter/shm_types.h
 
 libcounter_la_LIBADD = -lrt
 
@@ -72,11 +77,11 @@ endif
 libcounter_la_CFLAGS = -DUST_COMPONENT="libcounter" $(AM_CFLAGS)
 
 # msgpack
-msgpack_libmsgpack_la_SOURCES = \
+libmsgpack_la_SOURCES = \
        msgpack/msgpack.c \
        msgpack/msgpack.h
 
-msgpack_libmsgpack_la_CFLAGS = -DUST_COMPONENT="libmsgpack" $(AM_CFLAGS)
+libmsgpack_la_CFLAGS = -DUST_COMPONENT="libmsgpack" $(AM_CFLAGS)
 
 # ringbuffer
 libringbuffer_la_SOURCES = \
@@ -88,7 +93,6 @@ libringbuffer_la_SOURCES = \
        ringbuffer/frontend.h \
        ringbuffer/frontend_internal.h \
        ringbuffer/frontend_types.h \
-       ringbuffer/getcpu.h \
        ringbuffer/nohz.h \
        ringbuffer/rb-init.h \
        ringbuffer/ring_buffer_backend.c \
@@ -98,8 +102,6 @@ libringbuffer_la_SOURCES = \
        ringbuffer/shm.h \
        ringbuffer/shm_internal.h \
        ringbuffer/shm_types.h \
-       ringbuffer/smp.c \
-       ringbuffer/smp.h \
        ringbuffer/vatomic.h
 
 libringbuffer_la_LIBADD = \
@@ -112,7 +114,7 @@ endif
 libringbuffer_la_CFLAGS = -DUST_COMPONENT="libringbuffer" $(AM_CFLAGS)
 
 # snprintf
-snprintf_libsnprintf_la_SOURCES = \
+libsnprintf_la_SOURCES = \
        snprintf/fflush.c \
        snprintf/fileext.h \
        snprintf/floatio.h \
@@ -128,13 +130,26 @@ snprintf_libsnprintf_la_SOURCES = \
 
 # Common library
 libcommon_la_SOURCES = \
+       dynamic-type.c \
+       dynamic-type.h \
+       elf.c \
+       elf.h \
+       events.c \
+       getenv.c \
+       getenv.h \
        logging.c \
        logging.h \
+       smp.c \
+       smp.h \
+       strutils.c \
+       strutils.h \
+       utils.c \
+       utils.h \
        patient.c
 
 libcommon_la_LIBADD = \
-       msgpack/libmsgpack.la \
-       snprintf/libsnprintf.la
+       libmsgpack.la \
+       libsnprintf.la
 
 libustcomm_la_SOURCES = \
        ustcomm.c \
This page took 0.033102 seconds and 4 git commands to generate.