Make futex compat internal to liblttng-ust
[lttng-ust.git] / src / common / Makefile.am
index e73cc1fa95f65c203eeba5c06ad17b5dbbe7c625..f4c134a704685a0358eec114834c91d4878ec090 100644 (file)
@@ -10,16 +10,26 @@ noinst_HEADERS = \
        align.h \
        bitfield.h \
        bitmap.h \
-       dynamic-type.h \
-       elf.h \
+       clock.h \
+       creds.h \
+       err-ptr.h \
+       events.h \
+       hash.h \
+       jhash.h \
        logging.h \
        macros.h \
+       ns.h \
        patient.h \
+       procname.h \
        safe-snprintf.h \
-       ustcomm.h
+       tracepoint.h \
+       wait.h
 
 noinst_HEADERS += \
        compat/dlfcn.h \
+       compat/errno.h \
+       compat/mmap.h \
+       compat/pthread.h \
        compat/tid.h
 
 # These headers should be moved to the public headers when tested and
@@ -38,11 +48,73 @@ noinst_HEADERS += \
 ###                      ###
 
 noinst_LTLIBRARIES = \
-       snprintf/libsnprintf.la \
-       libcommon.la
+       libcounter.la \
+       libmsgpack.la \
+       libringbuffer.la \
+       libsnprintf.la \
+       libcommon.la \
+       libustcomm.la
+
+# counter
+libcounter_la_SOURCES = \
+       counter/counter-api.h \
+       counter/counter.c \
+       counter/counter-config.h \
+       counter/counter.h \
+       counter/counter-internal.h \
+       counter/counter-types.h \
+       counter/shm.c \
+       counter/shm.h \
+       counter/shm_internal.h \
+       counter/shm_types.h
+
+libcounter_la_LIBADD = -lrt
+
+if ENABLE_NUMA
+libcounter_la_LIBADD += -lnuma
+endif
+
+libcounter_la_CFLAGS = -DUST_COMPONENT="libcounter" $(AM_CFLAGS)
+
+# msgpack
+libmsgpack_la_SOURCES = \
+       msgpack/msgpack.c \
+       msgpack/msgpack.h
+
+libmsgpack_la_CFLAGS = -DUST_COMPONENT="libmsgpack" $(AM_CFLAGS)
+
+# ringbuffer
+libringbuffer_la_SOURCES = \
+       ringbuffer/api.h \
+       ringbuffer/backend.h \
+       ringbuffer/backend_internal.h \
+       ringbuffer/backend_types.h \
+       ringbuffer/frontend_api.h \
+       ringbuffer/frontend.h \
+       ringbuffer/frontend_internal.h \
+       ringbuffer/frontend_types.h \
+       ringbuffer/nohz.h \
+       ringbuffer/rb-init.h \
+       ringbuffer/ring_buffer_backend.c \
+       ringbuffer/ringbuffer-config.h \
+       ringbuffer/ring_buffer_frontend.c \
+       ringbuffer/shm.c \
+       ringbuffer/shm.h \
+       ringbuffer/shm_internal.h \
+       ringbuffer/shm_types.h \
+       ringbuffer/vatomic.h
+
+libringbuffer_la_LIBADD = \
+       -lrt
+
+if ENABLE_NUMA
+libringbuffer_la_LIBADD += -lnuma
+endif
+
+libringbuffer_la_CFLAGS = -DUST_COMPONENT="libringbuffer" $(AM_CFLAGS)
 
 # snprintf
-snprintf_libsnprintf_la_SOURCES = \
+libsnprintf_la_SOURCES = \
        snprintf/fflush.c \
        snprintf/fileext.h \
        snprintf/floatio.h \
@@ -58,11 +130,29 @@ snprintf_libsnprintf_la_SOURCES = \
 
 # Common library
 libcommon_la_SOURCES = \
+       dynamic-type.c \
+       dynamic-type.h \
+       elf.c \
+       elf.h \
+       events.c \
+       getenv.c \
+       getenv.h \
        logging.c \
        logging.h \
+       smp.c \
+       smp.h \
+       strutils.c \
+       strutils.h \
+       utils.c \
+       utils.h \
        patient.c
 
 libcommon_la_LIBADD = \
-       snprintf/libsnprintf.la
+       libmsgpack.la \
+       libsnprintf.la
+
+libustcomm_la_SOURCES = \
+       ustcomm.c \
+       ustcomm.h
 
 EXTRA_DIST = snprintf/README
This page took 0.02654 seconds and 4 git commands to generate.