Make futex compat internal to liblttng-ust
[lttng-ust.git] / src / common / Makefile.am
index a53e4ce750404f3dbe7e9c59f64a0bc2049e18fc..f4c134a704685a0358eec114834c91d4878ec090 100644 (file)
@@ -12,8 +12,6 @@ noinst_HEADERS = \
        bitmap.h \
        clock.h \
        creds.h \
-       dynamic-type.h \
-       elf.h \
        err-ptr.h \
        events.h \
        hash.h \
@@ -51,7 +49,6 @@ noinst_HEADERS += \
 
 noinst_LTLIBRARIES = \
        libcounter.la \
-       libcompat.la \
        libmsgpack.la \
        libringbuffer.la \
        libsnprintf.la \
@@ -79,11 +76,6 @@ endif
 
 libcounter_la_CFLAGS = -DUST_COMPONENT="libcounter" $(AM_CFLAGS)
 
-# compat
-libcompat_la_SOURCES = \
-       compat/futex.c \
-       compat/futex.h
-
 # msgpack
 libmsgpack_la_SOURCES = \
        msgpack/msgpack.c \
@@ -138,6 +130,11 @@ libsnprintf_la_SOURCES = \
 
 # Common library
 libcommon_la_SOURCES = \
+       dynamic-type.c \
+       dynamic-type.h \
+       elf.c \
+       elf.h \
+       events.c \
        getenv.c \
        getenv.h \
        logging.c \
@@ -146,10 +143,11 @@ libcommon_la_SOURCES = \
        smp.h \
        strutils.c \
        strutils.h \
+       utils.c \
+       utils.h \
        patient.c
 
 libcommon_la_LIBADD = \
-       libcompat.la \
        libmsgpack.la \
        libsnprintf.la
 
This page took 0.024556 seconds and 4 git commands to generate.