Make futex compat internal to liblttng-ust
[lttng-ust.git] / src / common / Makefile.am
index 177ef070dcbacdb8e4c5a4c596d2ef32c54a081c..f4c134a704685a0358eec114834c91d4878ec090 100644 (file)
@@ -10,13 +10,19 @@ noinst_HEADERS = \
        align.h \
        bitfield.h \
        bitmap.h \
-       dynamic-type.h \
-       elf.h \
+       clock.h \
+       creds.h \
+       err-ptr.h \
+       events.h \
+       hash.h \
+       jhash.h \
        logging.h \
        macros.h \
+       ns.h \
        patient.h \
        procname.h \
        safe-snprintf.h \
+       tracepoint.h \
        wait.h
 
 noinst_HEADERS += \
@@ -60,9 +66,7 @@ libcounter_la_SOURCES = \
        counter/shm.c \
        counter/shm.h \
        counter/shm_internal.h \
-       counter/shm_types.h \
-       counter/smp.c \
-       counter/smp.h
+       counter/shm_types.h
 
 libcounter_la_LIBADD = -lrt
 
@@ -89,7 +93,6 @@ libringbuffer_la_SOURCES = \
        ringbuffer/frontend.h \
        ringbuffer/frontend_internal.h \
        ringbuffer/frontend_types.h \
-       ringbuffer/getcpu.h \
        ringbuffer/nohz.h \
        ringbuffer/rb-init.h \
        ringbuffer/ring_buffer_backend.c \
@@ -99,8 +102,6 @@ libringbuffer_la_SOURCES = \
        ringbuffer/shm.h \
        ringbuffer/shm_internal.h \
        ringbuffer/shm_types.h \
-       ringbuffer/smp.c \
-       ringbuffer/smp.h \
        ringbuffer/vatomic.h
 
 libringbuffer_la_LIBADD = \
@@ -129,8 +130,21 @@ libsnprintf_la_SOURCES = \
 
 # Common library
 libcommon_la_SOURCES = \
+       dynamic-type.c \
+       dynamic-type.h \
+       elf.c \
+       elf.h \
+       events.c \
+       getenv.c \
+       getenv.h \
        logging.c \
        logging.h \
+       smp.c \
+       smp.h \
+       strutils.c \
+       strutils.h \
+       utils.c \
+       utils.h \
        patient.c
 
 libcommon_la_LIBADD = \
This page took 0.025428 seconds and 4 git commands to generate.