Build system: implement REUSE with SPDX identifiers
[lttng-ust.git] / src / common / Makefile.am
index 2fbc8fffacf2db9242493bec043134613e08e9ff..3561032bbff81efac0b8a7d58cf98aa99eca677b 100644 (file)
@@ -1,3 +1,5 @@
+# SPDX-FileCopyrightText: 2023 EfficiOS, Inc
+#
 # SPDX-License-Identifier: LGPL-2.1-only
 
 AUTOMAKE_OPTIONS = subdir-objects
@@ -10,16 +12,28 @@ noinst_HEADERS = \
        align.h \
        bitfield.h \
        bitmap.h \
-       dynamic-type.h \
-       elf.h \
+       clock.h \
+       creds.h \
+       err-ptr.h \
+       events.h \
+       getcpu.h \
+       hash.h \
+       jhash.h \
        logging.h \
        macros.h \
+       ns.h \
        patient.h \
+       procname.h \
        safe-snprintf.h \
-       ustcomm.h
+       tracepoint.h \
+       tracer.h \
+       wait.h
 
 noinst_HEADERS += \
        compat/dlfcn.h \
+       compat/errno.h \
+       compat/mmap.h \
+       compat/pthread.h \
        compat/tid.h
 
 # These headers should be moved to the public headers when tested and
@@ -39,10 +53,13 @@ noinst_HEADERS += \
 
 noinst_LTLIBRARIES = \
        libcounter.la \
-       msgpack/libmsgpack.la \
+       libcounter-clients.la \
+       libmsgpack.la \
        libringbuffer.la \
-       snprintf/libsnprintf.la \
-       libcommon.la
+       libringbuffer-clients.la \
+       libsnprintf.la \
+       libcommon.la \
+       libustcomm.la
 
 # counter
 libcounter_la_SOURCES = \
@@ -55,9 +72,7 @@ libcounter_la_SOURCES = \
        counter/shm.c \
        counter/shm.h \
        counter/shm_internal.h \
-       counter/shm_types.h \
-       counter/smp.c \
-       counter/smp.h
+       counter/shm_types.h
 
 libcounter_la_LIBADD = -lrt
 
@@ -67,12 +82,21 @@ endif
 
 libcounter_la_CFLAGS = -DUST_COMPONENT="libcounter" $(AM_CFLAGS)
 
+# counter-clients
+libcounter_clients_la_SOURCES = \
+       counter-clients/clients.c \
+       counter-clients/clients.h \
+       counter-clients/percpu-32-modular.c \
+       counter-clients/percpu-64-modular.c
+
+libcounter_clients_la_CFLAGS = -DUST_COMPONENT="libcounter-clients" $(AM_CFLAGS)
+
 # msgpack
-msgpack_libmsgpack_la_SOURCES = \
+libmsgpack_la_SOURCES = \
        msgpack/msgpack.c \
        msgpack/msgpack.h
 
-msgpack_libmsgpack_la_CFLAGS = -DUST_COMPONENT="libmsgpack" $(AM_CFLAGS)
+libmsgpack_la_CFLAGS = -DUST_COMPONENT="libmsgpack" $(AM_CFLAGS)
 
 # ringbuffer
 libringbuffer_la_SOURCES = \
@@ -84,8 +108,6 @@ libringbuffer_la_SOURCES = \
        ringbuffer/frontend.h \
        ringbuffer/frontend_internal.h \
        ringbuffer/frontend_types.h \
-       ringbuffer/getcpu.h \
-       ringbuffer/mmap.h \
        ringbuffer/nohz.h \
        ringbuffer/rb-init.h \
        ringbuffer/ring_buffer_backend.c \
@@ -95,8 +117,6 @@ libringbuffer_la_SOURCES = \
        ringbuffer/shm.h \
        ringbuffer/shm_internal.h \
        ringbuffer/shm_types.h \
-       ringbuffer/smp.c \
-       ringbuffer/smp.h \
        ringbuffer/vatomic.h
 
 libringbuffer_la_LIBADD = \
@@ -108,8 +128,22 @@ endif
 
 libringbuffer_la_CFLAGS = -DUST_COMPONENT="libringbuffer" $(AM_CFLAGS)
 
+# ringbuffer-client
+libringbuffer_clients_la_SOURCES = \
+       ringbuffer-clients/clients.c \
+       ringbuffer-clients/clients.h \
+       ringbuffer-clients/discard.c \
+       ringbuffer-clients/discard-rt.c \
+       ringbuffer-clients/metadata.c \
+       ringbuffer-clients/metadata-template.h \
+       ringbuffer-clients/overwrite.c \
+       ringbuffer-clients/overwrite-rt.c \
+       ringbuffer-clients/template.h
+
+libringbuffer_clients_la_CFLAGS = -DUST_COMPONENT="libringbuffer-clients" $(AM_CFLAGS)
+
 # snprintf
-snprintf_libsnprintf_la_SOURCES = \
+libsnprintf_la_SOURCES = \
        snprintf/fflush.c \
        snprintf/fileext.h \
        snprintf/floatio.h \
@@ -125,12 +159,30 @@ snprintf_libsnprintf_la_SOURCES = \
 
 # Common library
 libcommon_la_SOURCES = \
+       core.c \
+       dynamic-type.c \
+       dynamic-type.h \
+       elf.c \
+       elf.h \
+       events.c \
+       getenv.c \
+       getenv.h \
        logging.c \
        logging.h \
+       smp.c \
+       smp.h \
+       strutils.c \
+       strutils.h \
+       utils.c \
+       utils.h \
        patient.c
 
 libcommon_la_LIBADD = \
-       msgpack/libmsgpack.la \
-       snprintf/libsnprintf.la
+       libmsgpack.la \
+       libsnprintf.la
+
+libustcomm_la_SOURCES = \
+       ustcomm.c \
+       ustcomm.h
 
 EXTRA_DIST = snprintf/README
This page took 0.024471 seconds and 4 git commands to generate.