Fix: baddr_statedump tracepoint registration
[lttng-ust.git] / liblttng-ust / Makefile.am
index fef43c2466956dca38c94fbf497ed086ef4500f8..e9022d8a469d899f2910cf1931006fbc7538fa78 100644 (file)
@@ -1,41 +1,67 @@
-AM_CPPFLAGS = -I$(top_srcdir)/include
+AM_CPPFLAGS = -I$(top_srcdir)/include -I$(top_builddir)/include
 AM_CFLAGS = -fno-strict-aliasing
 
 noinst_LTLIBRARIES = liblttng-ust-runtime.la liblttng-ust-support.la
 
-lib_LTLIBRARIES = liblttng-ust.la
+lib_LTLIBRARIES = liblttng-ust-tracepoint.la liblttng-ust.la
+
+liblttng_ust_tracepoint_la_SOURCES = \
+       tracepoint.c \
+       tracepoint-internal.h \
+       lttng-tracer-core.h \
+       jhash.h \
+       error.h
+liblttng_ust_tracepoint_la_LIBADD = \
+       -lurcu-bp \
+       $(top_builddir)/snprintf/libustsnprintf.la
+liblttng_ust_tracepoint_la_LDFLAGS = -no-undefined -version-info $(LTTNG_UST_LIBRARY_VERSION)
+liblttng_ust_tracepoint_la_CFLAGS = -DUST_COMPONENT="liblttng_ust_tracepoint" -fno-strict-aliasing
 
 liblttng_ust_runtime_la_SOURCES = \
        lttng-ust-comm.c \
        lttng-ust-abi.c \
-       ltt-probes.c \
-       probes/lttng-probe-ust.c \
-       probes/lttng-probe-ust.h \
+       lttng-probes.c \
        lttng-context-vtid.c \
        lttng-context-vpid.c \
        lttng-context-pthread-id.c \
        lttng-context-procname.c \
-       ltt-context.c \
-       ltt-events.c \
-       tracepoint.c \
+       lttng-context-ip.c \
+       lttng-context.c \
+       lttng-events.c \
+       lttng-filter.c \
+       lttng-filter.h \
+       lttng-filter-validator.c \
+       lttng-filter-specialize.c \
+       lttng-filter-interpreter.c \
+       filter-bytecode.h \
+       lttng-hash-helper.h \
+       lttng-ust-baddr.c \
+       lttng-ust-baddr.h \
+       ust_baddr_statedump.h \
        tracepoint-internal.h \
        clock.h \
+       compat.h \
        wait.h \
-       jhash.h
+       jhash.h \
+       lttng-ust-uuid.h \
+       error.h
 
 liblttng_ust_support_la_SOURCES = \
-       ltt-tracer.h \
-       ltt-tracer-core.h \
+       lttng-tracer.h \
+       lttng-tracer-core.h \
        ust-core.c \
-       ltt-ring-buffer-client.h \
-       ltt-ring-buffer-client-discard.c \
-       ltt-ring-buffer-client-overwrite.c \
-       ltt-ring-buffer-metadata-client.h \
-       ltt-ring-buffer-metadata-client.c
+       lttng-rb-clients.h \
+       lttng-ring-buffer-client.h \
+       lttng-ring-buffer-client-discard.c \
+       lttng-ring-buffer-client-discard-rt.c \
+       lttng-ring-buffer-client-overwrite.c \
+       lttng-ring-buffer-client-overwrite-rt.c \
+       lttng-ring-buffer-metadata-client.h \
+       lttng-ring-buffer-metadata-client.c
 
 liblttng_ust_la_SOURCES =
 
-liblttng_ust_la_LDFLAGS = -no-undefined -version-info 0:0:0
+liblttng_ust_la_LDFLAGS = -no-undefined -version-info $(LTTNG_UST_LIBRARY_VERSION)
 
 liblttng_ust_support_la_LIBADD = \
        $(top_builddir)/libringbuffer/libringbuffer.la
@@ -43,9 +69,10 @@ liblttng_ust_support_la_LIBADD = \
 liblttng_ust_la_LIBADD = \
        -lpthread \
        -lrt \
-       -luuid \
+       -lurcu-cds \
        $(top_builddir)/snprintf/libustsnprintf.la \
        $(top_builddir)/liblttng-ust-comm/liblttng-ust-comm.la \
+       liblttng-ust-tracepoint.la \
        liblttng-ust-runtime.la liblttng-ust-support.la
 
-liblttng_ust_la_CFLAGS = -DUST_COMPONENT="liblttng-ust" -fno-strict-aliasing
+liblttng_ust_la_CFLAGS = -DUST_COMPONENT="liblttng_ust" -fno-strict-aliasing
This page took 0.024141 seconds and 4 git commands to generate.