ust-fd: Add close_range declaration
[lttng-ust.git] / include / Makefile.am
index e703ffd094949eaf8c60b7b50d82576c5052170b..368fa2613b2de16a229fabca6715174e55d40f46 100644 (file)
@@ -1,23 +1,49 @@
+# SPDX-FileCopyrightText: 2023 EfficiOS, Inc
+#
+# SPDX-License-Identifier: LGPL-2.1-only
+
+###                    ###
+### Public API headers ###
+###                    ###
+
 nobase_include_HEADERS = \
-       ust/immediate.h \
-       ust/marker.h \
-       ust/tracepoint.h \
-       ust/define_trace.h \
-       ust/ust_trace.h \
-       ust/processor.h \
-       ust/probe.h \
-       ust/ust.h \
-       ust/tracectl.h \
-       ust/core.h \
-       ust/clock.h \
-       ust/type-serializer.h \
-       ust/kcompat/kcompat.h \
-       ust/kcompat/compiler.h \
-       ust/kcompat/jhash.h \
-       ust/kcompat/simple.h \
-       ust/kcompat/types.h \
-       ust/kcompat/stringify.h \
-       ust/ustctl.h \
-       ust/ustconsumer.h
+       lttng/tracepoint.h \
+       lttng/tracepoint-rcu.h \
+       lttng/tracepoint-types.h \
+       lttng/tracepoint-event.h \
+       lttng/ust-tracepoint-event.h \
+       lttng/ust-tracepoint-event-reset.h \
+       lttng/ust-tracepoint-event-write.h \
+       lttng/ust-tracepoint-event-nowrite.h \
+       lttng/ust-api-compat.h \
+       lttng/ust-arch.h \
+       lttng/ust-events.h \
+       lttng/ust-common.h \
+       lttng/ust-ctl.h \
+       lttng/ust-abi.h \
+       lttng/ust-tracer.h \
+       lttng/ust-compiler.h \
+       lttng/ust-fork.h \
+       lttng/ust-endian.h \
+       lttng/ust-ringbuffer-context.h \
+       lttng/ust-utils.h \
+       lttng/ust-error.h \
+       lttng/tracef.h \
+       lttng/tp/lttng-ust-tracef.h \
+       lttng/tracelog.h \
+       lttng/tp/lttng-ust-tracelog.h \
+       lttng/ust-clock.h \
+       lttng/ust-getcpu.h \
+       lttng/ust-libc-wrapper.h \
+       lttng/ust-thread.h \
+       lttng/urcu/pointer.h \
+       lttng/urcu/urcu-ust.h \
+       lttng/urcu/static/pointer.h \
+       lttng/urcu/static/urcu-ust.h \
+       lttng/ust-sigbus.h \
+       lttng/ust-cancelstate.h
 
-noinst_HEADERS = share.h usterr.h ust_snprintf.h
+# Auto-generated by configure.
+nobase_nodist_include_HEADERS = \
+       lttng/ust-config.h \
+       lttng/ust-version.h
This page took 0.02796 seconds and 4 git commands to generate.