doc: xmlto output to stdout on a verbose build
[lttng-ust.git] / doc / man / Makefile.am
index 9cee98d13d163aa69bca82d74fc96f8f29982607..dfc319a42eab1c6a8856f62ada2b76b19a5308eb 100644 (file)
@@ -49,7 +49,7 @@ MAN1 = $(addsuffix .1,$(MAN1_NAMES))
 MAN3 = $(addsuffix .3,$(MAN3_NAMES)) $(MAN3_ALIASES)
 MAN = $(MAN1) $(MAN3)
 
-if MAN_PAGES_OPT
+if ENABLE_MAN_PAGES
 # At this point, we know the user asked to build the man pages.
 if HAVE_ASCIIDOC_XMLTO
 
@@ -61,9 +61,12 @@ xmlto_verbose = $(xmlto_verbose_@AM_V@)
 xmlto_verbose_ = $(xmlto_verbose_@AM_DEFAULT_V@)
 xmlto_verbose_0 = @echo "  XMLTO     " $@;
 
+xmlto_verbose_out = $(xmlto_verbose_out_@AM_V@)
+xmlto_verbose_out_ = $(xmlto_verbose_out_@AM_DEFAULT_V@)
+xmlto_verbose_out_0 = 2>/dev/null
+
 # Tools to execute:
 ADOC = $(asciidoc_verbose)$(ASCIIDOC) -f $(ASCIIDOC_CONF) -d manpage \
-       -a lttng_ust_register_timeout="@LTTNG_UST_DEFAULT_CONSTRUCTOR_TIMEOUT_MS@" \
        -a mansource="LTTng" \
        -a manmanual="LTTng Manual" \
        -a manversion="$(PACKAGE_VERSION)"
@@ -76,19 +79,30 @@ XTO = $(xmlto_verbose)$(XMLTO) -m $(XSL_FILE) man
        $(ADOC_DOCBOOK) -o $@ $<
 
 %.1: %.1.xml $(XSL_FILE)
-       $(XTO) $< 2>/dev/null
+       $(XTO) $< $(xmlto_verbose_out)
 
 %.3.xml: $(srcdir)/%.3.txt $(COMMON_DEPS)
        $(ADOC_DOCBOOK) -o $@ $<
 
-tracef.3 vtracef.3 &: tracef.3.xml $(XSL_FILE)
-       $(XTO) $< 2>/dev/null
+# These pair of files are generated by a single invocation of xmlto, use an
+# empty rule that depends on a fake intermediate file to track the dependencies
+# without resorting to Group Targets which were only introduced in GNU Make 4.3.
+tracef.3 vtracef.3: tracef.3.alias
+       @# Empty recipe to mark tracef.3 and vtracef.3 as rebuilt
+
+tracelog.3 vtracelog.3: tracelog.3.alias
+       @# Empty recipe to mark tracelog.3 and vtracelog.3 as rebuilt
+
+.INTERMEDIATE: tracef.3.alias tracelog.3.alias
+
+tracef.3.alias: tracef.3.xml $(XSL_FILE)
+       $(XTO) $< $(xmlto_verbose_out)
 
-tracelog.3 vtracelog.3 &: tracelog.3.xml $(XSL_FILE)
-       $(XTO) $< 2>/dev/null
+tracelog.3.alias: tracelog.3.xml $(XSL_FILE)
+       $(XTO) $< $(xmlto_verbose_out)
 
 %.3: %.3.xml $(XSL_FILE)
-       $(XTO) $< 2>/dev/null
+       $(XTO) $< $(xmlto_verbose_out)
 
 # Only clean the generated files if we have the tools to generate them again.
 CLEANFILES = $(MAN_XML) $(MAN)
@@ -106,28 +120,28 @@ ERR_MSG += "Make sure both tools are installed and run the configure script agai
        @echo $(ERR_MSG)
        @false
 endif # HAVE_ASCIIDOC_XMLTO
-endif # MAN_PAGES_OPT
+endif # ENABLE_MAN_PAGES
 
 # Start with empty distributed/installed man pages:
 dist_man1_MANS =
 dist_man3_MANS =
 EXTRA_DIST =
 
-if MAN_PAGES_OPT
+if ENABLE_MAN_PAGES
 # Building man pages: we can install and distribute them.
 dist_man1_MANS += $(MAN1)
 dist_man3_MANS += $(MAN3) $(MAN3_TROFF)
-else # MAN_PAGES_OPT
+else # ENABLE_MAN_PAGES
 # Those are not known by automake yet because dist_man3_MANS is empty
 # at this point, so make sure they are distributed.
 EXTRA_DIST += $(MAN3_TROFF)
-endif # MAN_PAGES_OPT
+endif # ENABLE_MAN_PAGES
 
-if !MAN_PAGES_OPT
+if !ENABLE_MAN_PAGES
 dist-hook:
        @echo "Error: Please enable the man pages before creating a distribution tarball."
        @false
-endif # !MAN_PAGES_OPT
+endif # !ENABLE_MAN_PAGES
 
 # Always distribute the source files.
 EXTRA_DIST += $(MAN_TXT) $(COMMON_TXT) $(XSL_FILE) $(ASCIIDOC_CONF) README.md
This page took 0.024597 seconds and 4 git commands to generate.