doc: pass AR when building examples
[lttng-ust.git] / doc / examples / Makefile.am
index d5d00b090c61acaa194b7a009a448de7286ea205..2f9811ea4f9bfbc8b05e8e4644d4833d3996e2d0 100644 (file)
@@ -123,7 +123,7 @@ all-local:
                rel_build_subdir="../"; \
        fi; \
        for subdir in $(SUBDIRS_PROXY); do \
                rel_build_subdir="../"; \
        fi; \
        for subdir in $(SUBDIRS_PROXY); do \
-               (cd $$subdir && $(MAKE) CC="$(CC)" CPPFLAGS="$(CPPFLAGS)" AM_CPPFLAGS="$(AM_CPPFLAGS) -I$$rel_src_subdir$(top_srcdir)/include/ -I$$rel_build_subdir$(top_builddir)/include/" CFLAGS='$(CFLAGS)' AM_CFLAGS='$(AM_CFLAGS)' LDFLAGS="$(LDFLAGS)" AM_LDFLAGS='$(AM_LDFLAGS) -L../../../liblttng-ust/.libs -Wl,-rpath="$(PWD)/../../liblttng-ust/.libs/" -Wl,-rpath-link="$(PWD)/../../liblttng-ust/.libs/"' LTTNG_GEN_TP_PATH="../../../tools/" AM_V_P="$(AM_V_P)" AM_V_at="$(AM_V_at)" $(AM_MAKEFLAGS) all && cd ..) || exit 1; \
+               (cd $$subdir && $(MAKE) AR="$(AR)" CC="$(CC)" CPPFLAGS="$(CPPFLAGS)" AM_CPPFLAGS="$(AM_CPPFLAGS) -I$$rel_src_subdir$(top_srcdir)/include/ -I$$rel_build_subdir$(top_builddir)/include/" CFLAGS='$(CFLAGS)' AM_CFLAGS='$(AM_CFLAGS)' LDFLAGS="$(LDFLAGS)" AM_LDFLAGS='$(AM_LDFLAGS) -L../../../liblttng-ust/.libs -Wl,-rpath="$(PWD)/../../liblttng-ust/.libs/" -Wl,-rpath-link="$(PWD)/../../liblttng-ust/.libs/"' LTTNG_GEN_TP_PATH="../../../tools/" AM_V_P="$(AM_V_P)" AM_V_at="$(AM_V_at)" $(AM_MAKEFLAGS) all && cd ..) || exit 1; \
        done; \
        if [ x"$(SUBDIRS_JUL)" != x"" ]; then \
                for subdir in $(SUBDIRS_JUL); do \
        done; \
        if [ x"$(SUBDIRS_JUL)" != x"" ]; then \
                for subdir in $(SUBDIRS_JUL); do \
@@ -141,6 +141,7 @@ all-local:
                                cd $$subdir && \
                                $(MKDIR_P) build && \
                                cd build && \
                                cd $$subdir && \
                                $(MKDIR_P) build && \
                                cd build && \
+                               AR="$(AR)" \
                                CC="$(CC)" \
                                CXX="$(CXX)" \
                                cmake \
                                CC="$(CC)" \
                                CXX="$(CXX)" \
                                cmake \
This page took 0.023348 seconds and 4 git commands to generate.