doc: pass AR when building examples
[lttng-ust.git] / doc / examples / Makefile.am
index 9c72afa316de6d842b5c74b27b74267a253c3cb7..2f9811ea4f9bfbc8b05e8e4644d4833d3996e2d0 100644 (file)
@@ -106,28 +106,24 @@ SUBDIRS_PROXY += gen-tp
 endif
 
 all-local:
-       @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
+       $(AM_V_at)if [ x"$(srcdir)" != x"$(builddir)" ]; then \
                for subdir in $(SUBDIRS_PROXY) $(SUBDIRS_JUL) $(SUBDIRS_LOG4J) $(SUBDIRS_CMAKE); do \
                        cp -pfR $(srcdir)/$$subdir $(builddir); \
                        chmod -R u+w $(builddir)/$$subdir; \
                done; \
        fi; \
        if [ x"$(shell echo "$(top_srcdir)" | grep "^/" | wc -l)" = x"1" ]; then \
-               echo "Examples: absolute top_srcdir path $(top_srcdir)"; \
                rel_src_subdir=""; \
        else \
-               echo "Examples: relative top_srcdir path $(top_srcdir)"; \
                rel_src_subdir="../"; \
        fi; \
        if [ x"$(shell echo "$(top_builddir)" | grep "^/" | wc -l)" = x"1" ]; then \
-               echo "Examples: absolute top_builddir path $(top_builddir)"; \
                rel_build_subdir=""; \
        else \
-               echo "Examples: relative top_builddir path $(top_builddir)"; \
                rel_build_subdir="../"; \
        fi; \
        for subdir in $(SUBDIRS_PROXY); do \
-               (cd $$subdir && $(MAKE) CC="$(CC)" CPPFLAGS="$(CPPFLAGS)" AM_CPPFLAGS="$(AM_CPPFLAGS) -I$$rel_src_subdir$(top_srcdir)/include/ -I$$rel_build_subdir$(top_builddir)/include/" CFLAGS='$(CFLAGS)' AM_CFLAGS='$(AM_CFLAGS)' LDFLAGS="$(LDFLAGS)" AM_LDFLAGS='$(AM_LDFLAGS) -L../../../liblttng-ust/.libs -Wl,-rpath="$(PWD)/../../liblttng-ust/.libs/" -Wl,-rpath-link="$(PWD)/../../liblttng-ust/.libs/"' LTTNG_GEN_TP_PATH="../../../tools/" $(AM_MAKEFLAGS) all && cd ..) || exit 1; \
+               (cd $$subdir && $(MAKE) AR="$(AR)" CC="$(CC)" CPPFLAGS="$(CPPFLAGS)" AM_CPPFLAGS="$(AM_CPPFLAGS) -I$$rel_src_subdir$(top_srcdir)/include/ -I$$rel_build_subdir$(top_builddir)/include/" CFLAGS='$(CFLAGS)' AM_CFLAGS='$(AM_CFLAGS)' LDFLAGS="$(LDFLAGS)" AM_LDFLAGS='$(AM_LDFLAGS) -L../../../liblttng-ust/.libs -Wl,-rpath="$(PWD)/../../liblttng-ust/.libs/" -Wl,-rpath-link="$(PWD)/../../liblttng-ust/.libs/"' LTTNG_GEN_TP_PATH="../../../tools/" AM_V_P="$(AM_V_P)" AM_V_at="$(AM_V_at)" $(AM_MAKEFLAGS) all && cd ..) || exit 1; \
        done; \
        if [ x"$(SUBDIRS_JUL)" != x"" ]; then \
                for subdir in $(SUBDIRS_JUL); do \
@@ -145,8 +141,9 @@ all-local:
                                cd $$subdir && \
                                $(MKDIR_P) build && \
                                cd build && \
-                               CC=$(CC) \
-                               CXX=$(CXX) \
+                               AR="$(AR)" \
+                               CC="$(CC)" \
+                               CXX="$(CXX)" \
                                cmake \
                                -DCMAKE_INCLUDE_PATH="$(abs_top_srcdir)/include;$(abs_top_builddir)/include" \
                                -DCMAKE_LIBRARY_PATH="$(abs_top_builddir)/liblttng-ust/.libs" \
@@ -162,7 +159,7 @@ all-local:
 
 
 clean-local:
-       @for subdir in $(SUBDIRS_PROXY); do \
+       $(AM_V_at)for subdir in $(SUBDIRS_PROXY); do \
                if [ -d $$subdir ]; then \
                        (cd $$subdir && $(MAKE) $(AM_MAKEFLAGS) clean && cd ..) || exit 1; \
                fi; \
This page took 0.024182 seconds and 4 git commands to generate.