Fix: UST app major version check
authorDavid Goulet <dgoulet@efficios.com>
Fri, 17 Aug 2012 19:23:09 +0000 (15:23 -0400)
committerDavid Goulet <dgoulet@efficios.com>
Fri, 17 Aug 2012 19:23:09 +0000 (15:23 -0400)
Makes a direct match between the major version of the application and
the one supported by lttng-tools (==).

Note that this version numbering is an internal scheme between UST and
lttng-tools. It has no link whatsoever with the public version of the
toolchain.

The 2.1.0-rc1 release commit will make sure this version corresponds to
the UST rc1.

CC: Mathieu Desnoyers <mathieu.desnoyers@efficios.com>
Signed-off-by: David Goulet <dgoulet@efficios.com>
src/bin/lttng-sessiond/ust-app.c

index e5d8b5707dea19b10810a89ecae52191b189fc15..7f4e9f1e0c928df31c5b5a39b1614e54f22361f8 100644 (file)
@@ -2921,12 +2921,12 @@ int ust_app_validate_version(int sock)
        }
 
        /* Validate version */
-       if (app->version.major > UST_APP_MAJOR_VERSION) {
+       if (app->version.major != UST_APP_MAJOR_VERSION) {
                goto error;
        }
 
        DBG2("UST app PID %d is compatible with major version %d "
-                       "(supporting <= %d)", app->pid, app->version.major,
+                       "(supporting == %d)", app->pid, app->version.major,
                        UST_APP_MAJOR_VERSION);
        app->compatible = 1;
        rcu_read_unlock();
@@ -2935,7 +2935,7 @@ int ust_app_validate_version(int sock)
 
 error:
        DBG2("UST app PID %d is not compatible with major version %d "
-                       "(supporting <= %d)", app->pid, app->version.major,
+                       "(supporting == %d)", app->pid, app->version.major,
                        UST_APP_MAJOR_VERSION);
        app->compatible = 0;
        rcu_read_unlock();
This page took 0.037417 seconds and 4 git commands to generate.