Fix: support VPATH build for tests
[lttng-tools.git] / tests / utils / Makefile.am
index 931c865bc4efde14469e780d9038756d7f3199aa..b3d5929738f4d8c7d92b929763685ca3cda8c717 100644 (file)
@@ -2,3 +2,17 @@ SUBDIRS = tap testapp
 
 EXTRA_DIST = utils.sh test_utils.py babelstats.pl
 dist_noinst_SCRIPTS = utils.sh test_utils.py babelstats.pl
+
+all-local:
+       @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
+               for script in $(EXTRA_DIST); do \
+                       cp -f $(srcdir)/$$script $(builddir); \
+               done; \
+       fi
+
+clean-local:
+       @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
+               for script in $(EXTRA_DIST); do \
+                       rm -f $(builddir)/$$script; \
+               done; \
+       fi
This page took 0.022749 seconds and 4 git commands to generate.